3

Still looking for the upgrade to 18.04LTS option in my 17.10 32-bit Software Updater, but doesn't seem to be coming up, only 'normal' updates... thought it was 'out' by now... is there some lag time before it is available for upgrade to 17.10 users thru their software updater?

OR, is my Panasonic Toughbook laptop being boycotted due to minimum system requirements or something...?

  • I understood 'existing' 17.10 32-bit systems would be able to upgrade to a 32-bit 18.04... nothing about having to go to spin-offs... Also, a guy working on assisting in developing 18.04 said I was essentially already 'using' 18.04 with 17.10 as updated all these days. – The MAJOR Apr 27 '18 at 14:23
  • So - I just have to stay with 17.10 until support/updates put me out on the street, THEN worry about what to do - probably go back to my Vista64 office edition laptop again :-\ – The MAJOR Apr 27 '18 at 14:29
  • Did you try do-release-upgrade -d? The -d flag is needed until 18.04.1 version comes out. – WinEunuuchs2Unix Apr 29 '18 at 0:44
  • 1
    @WinEunuuchs2Unix that timeline stated is only for LTS -> LTS upgrades; a week or two after release 17.10 -> 18.04 should become 'unlocked' – Thomas Ward Apr 29 '18 at 17:11
  • ran "do-release-upgrade -d" and get this: Checking for a new Ubuntu release Upgrades to the development release are only available from the latest supported release. ...and I AM running 17.10, so? – The MAJOR May 1 '18 at 12:12
3

Canonical has finally removed 32-bit ubuntu from their support. So this means you can't get 32-bit 18.04. I believe 32-bit ubuntu will only continue in ubuntu flavours(lubuntu, edubuntu,etc). If you want to upgrade from 17.10, get a .iso file from one of the ubuntu flavours, either burn it to a cd, use startup disk creator to put it on a usb or mount the iso file via:

sudo mount *ubuntu.iso /mnt

You can either boot from it(if you put on a external medium) or find cdromupgrade. It should be in the root filesystem. Or you could try changing your repositorys to bionic instead of artful. You need to edit your sources.list file to do this though. It should be in /etc/apt/.

| improve this answer | |
  • 3
    Are you sure that OP can't upgraded to 18.04? My understanding is that Canonical Ltd. has stopped providing 32-bit iso images since Ubuntu 17.10, but they still support upgrading to the next release. – pomsky Apr 28 '18 at 12:10
  • 2
    ISO images are no longer supported, but i386 still exists in the repos, in theory you will still have 32bit support, but there's no ultimate ISO for it anymore. Further, 17.10 -> 18.04 takes a few days for that to be made available (and by 'days' i mean 'business days', not days in general) – Thomas Ward Apr 28 '18 at 22:02
  • As far as I understood it: 18.04 64-bit still has the 32-bit compatibility. So you can have a 18.04 64-bit system running 32-bit software. I never saw an official source say a 32-bit could be upgraded to 18.04. – Rinzwind May 11 '18 at 13:09
2

Apparently "install to 18.04 via downloaded ISO image" (64-bit only) was released in April, but the "software upgrade from 17.10 to 18.04" (32-bit and 64-bit) will 'happen' maybe by end of May or sometime in June... it's just that 17.10 has been burning-up my processor and causing my video to crash (video memory shared with processor issue?). On MAY 25th 2018, the 'software updater' finally passed along the upgrade!!!!!!!!!! (Looks & runs just like 17.10...)

| improve this answer | |
  • 1
    It is best to post a separate question on the 17.10 issue before it expires in July. Who knows you might be better off with 16.04 LTS or even 14.04 LTS which demand fewer CPU resources. – WinEunuuchs2Unix May 12 '18 at 16:14
  • Posted the temp thing elsewhere - "dirt" then "undersized fan" only replies - both = N/A... Anyway - May 23rd, 2018 and still no upgrade to 18.04 via 'software updater', so found this and tried: Upgrading from Ubuntu 17.10 To upgrade on a desktop system: Press Alt+F2 and type update-manager -c into the command box. Update Manager should open up and tell you that Ubuntu 18.04 LTS is now available. (it popped-up, but sez I'm all updated... no upgrade available notice at all) – The MAJOR May 23 '18 at 12:47
  • If not you can run /usr/lib/ubuntu-release-upgrader/check-new-release-gtk Click Upgrade and follow the on-screen instructions. (Which I did, but nothing ever 'comes up'... the command box just goes away and nothing happens - bug?) – The MAJOR May 23 '18 at 12:47
  • If I instead run /usr/lib/ubuntu-release-upgrader/check-new-release-gtk in a terminal, I get: ~$ /usr/lib/ubuntu-release-upgrader/check-new-release-gtk/usr/lib/ubuntu-release-upgrader/check-new-release-gtk:30: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded. from gi.repository import Gtk WARNING:root:timeout reached, exiting – The MAJOR May 23 '18 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.