2

I had installed Ubuntu 17.10 with xorg as default display driver. I had nvidia-384 drivers and everything worked, no issues.

I have upgraded the system today from 17.10 to find out that my default session is wayland on Nouveau drivers. I tried to switch to xorg but the screen freezes and I can't login. If I install latest nvidia-390 drivers and try to login with wayland it ends up in a endless Start job has been started and I can't get to gdm login screen.If I use it with open source drivers everything is choppy and doesn't work well.

Any ideas why xorg is not default like it suppose to be, and why I can't run GDM with xorg?

0

There currently seems to be many problems with nVidia drivers in Ubuntu, perhaps due to bugs on nVidia's side. Perhaps this will take some time to stabilize. For now, I reverted to nouveau open source drivers, I removed the previous manual /etc/X11/xorg.conf that was pointing at nvidia, and finally I had my i3 window manager again.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.