42

I have a Dell monitor set to a scale of 200%:

enter image description here

I then set the laptop built-in display to 100%:

enter image description here

However, if I then switch back to the Dell monitor settings, the scale there has reverted to 100%.

Is there a way to have 200% scale on the Dell monitor and 100% scale on the laptop monitor?

Thanks!

  • 1
    Did you try my answer ? Has it worked ? – Christ-OFF May 22 '18 at 19:18
  • I got this working with Wayland on Ubuntu 18. 32" 4k monitor at 200%, 14" 1080p Asus laptop at 100% – Neil McGuigan Feb 9 at 23:22
12

On Gnome 3.32 (default for Ubuntu 19.04) is possible to set up fractional scaling even for X. The command is:

gsettings set org.gnome.mutter experimental-features "['x11-randr-fractional-scaling']"

After that you can go to Display Settings and sets different scaling ratio for each monitor you have, even in 25% increments.

If, for any reason, you need to reset fractional scaling, the command is:

gsettings reset org.gnome.mutter experimental-features
| improve this answer | |
  • 1
    This works. On my machine, however, it degrades performance a ton. I have significant lag when resizing windows, scrolling, etc (I have Intel Integrated Graphics) – Aurélien Gasser Dec 16 '19 at 22:15
  • This works perfectly for me, however I am using an external graphics card. – Dan Pantry Apr 6 at 23:13
11

There is an easy workaround.
Instead of changing the scale: change the resolution of the monitor.
With a lower resolution on a 4K screen, you should be able to match the additional monitor.

Hope this helps.

| improve this answer | |
  • 1
    I can see the different resolutions but can't change to it on ubuntu 18.10 :( – roundcrisis Nov 26 '18 at 11:54
  • 1
    It's strange, sometimes the "apply" button disappears... And most resolutions don't match the screen ratio, which means I don't have the options I need to get a good scaling. – Christian Feb 11 '19 at 9:36
  • Have you seen this news : omgubuntu.co.uk/2019/03/best-gnome-3-32-features ? GNOME 3.32 -> Fractional Scaling in GNOME Shell So we may have it in 19.xx – Christ-OFF Mar 15 '19 at 6:13
  • 4
    This is a terrible work-around. If you do this, you won't get any of the benefits of the 4K display (that you presumably paid quite a lot for). Everything will simply be magnified x2 instead of showing the finer detail that the display is capable of. The whole point of a 4K display is to be able to display finer detail, with sharper, clearer images. You should always run an LCD at its native resolution. – hackel Dec 22 '19 at 21:44
10

Lower the resolution of monitor could solve the problem, but that's not a good solution because it sacrifice the 4k resolution.

Assume you are using x-window and ubuntu 18.04. A better but more sophisticated approach is: keep resolution of monitor to 4k, raise your laptop monitor resolution double and scale up all windows 200%. Detail step as follows:

  1. Go to setting > displays > set scale to 200%
  2. Connect to dell monitor, type xrandr to check for id of two monitors. Here I assume you have monitor 'HDMI-0' of 3840x2160, monitor 'HDMI-1' of 1600x900. Now I want to place 'HDMI-1' to left, 'HDMI-0' to right.
  3. Run the following

xrandr --dpi 276 --fb 7040x2160 --output HDMI-0 --mode 3840x2160 --pos 3200x0 --output HDMI-1 --scale 2x2 --panning 3200x1800+0+0

(Note: 7040 = 3840+1600x2, 3200=1600x2, 1800=900x2)

| improve this answer | |
  • This one is the correct answer for me though requires a bit calculation of screen sizes. But the display is flickering do you have any suggestions? – Dipendra Gurung Aug 18 '19 at 2:55
  • 2
    Could you go more into detail about what the values of the parameters dpi, fb, pos, mode and panning are doing exactly and how to calculate them? I have difficulties when I try to get my Dell XPS 13 (4k monitor with 3200x1800( and an external monitor placed physically above with 1920x1080. the scale for my dell monitor should be 200%, the one for the external should be 100% and it should virtually also be placed "upside" the dell monitor. I am not anyhow getting working settings (however somehow misplaced at least). Thanks! – ElectRocnic Nov 5 '19 at 13:03
9

You can have two different scales using Wayland
Wayland was the default in 17.04. X11 is the default in 18.04
To switch to wayland :
1. logout
2. On the login screen click on the little cog
3. and choose "Ubuntu on wayland"

| improve this answer | |
  • 1
    What if I don't have a "Ubuntu on wayland" option? How do I install or enable it? – Insasse May 30 '18 at 13:29
  • 2
    I was able to select "Ubuntu on wayland" and configure the scaling. Very few applications like the terminal & Ubuntu Software scale correctly. However, the majority of my applications such as my web browser and IDE do not scale, and remain at the scaling of the main monitor. How do I go about resolving this? – Tsume Jul 5 '18 at 14:05
  • 1
    @Tsume Did you ever fix it? – ljden Nov 7 '18 at 12:13
  • 3
    @ljden Yes, I did fix it. I think I used this fractional scaling to do it maketecheasier.com/enable-fractional-scaling-gnome – Tsume Nov 9 '18 at 13:39
  • 2
    Next - dual monitor setup with different DPI's? – danger89 Mar 14 '19 at 23:14
3

If you have NVIDIA cards, you can use NVIDIA X Server Settings. I tried @travis-wayland 's solution with different settings but always messed up the screens. Here is my settings for both displays (Ubuntu 18.04.2):

Left Screen and Right Screen

Notice that ViewPortIn and Panning must match while ViewPortOut is set to the maximum screen resolution (1680x1050). Also notice that I'm using my screen vertical, so XxY is flipped in ViewPortIn and Panning.

If you don't see NVIDIA X Server Settings among your applications, you may need to install/update your drivers. Btw, my computer uses NVIDIA drivers, not the built in X.Org (Nouveau driver). So make sure you are using NVIDIA driver in Software & Updates under Additional Drivers menu.

| improve this answer | |
  • thank you so much – gumlym Mar 26 at 17:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.