13

Been struggling with this for a few days now. I am an absolutely green and non-technical Ubuntu user (I like it for it's light-weight/malware-free nature).

I repaired a hinge in the laptop that necessitated disconnecting the laptop from the battery on the mobo. Potentially that changed some of my bios settings?

When I put the drive back into the computer, I began receiving an initramfs error on boot.

If I type "exit", I get: ALERT! UUID=xxxxxxxxxxxxxx does not exist. Dropping to a shell!

I've tried several fixes from around the web to no avail.

Very wierdly, I swapped the HD into another computer (it's an NVMe drive - so a little M.2 drive) and it booted up to my usual Ubuntu desktop/account/etc. without issue. This makes me think there isn't really any issue with my 'fstab' (which I don't actually know how to edit/can't access without swapping the drive into another computer), nor any kind of disk error. I'm willing to try chrisccoulson's solution from this post if any of you think it would help: https://ubuntuforums.org/showthread.php?t=813090

Regardless, I can't boot on the dell. I just get the initramfs/busybox error.

I've tried the following (swapping sda1 for my Linux partition, of course): sudo mount /dev/sda1 /mnt sudo mount --bind /dev /mnt/dev sudo mount --bind /proc /mnt/proc sudo mount --bind /sys /mnt/sys sudo chroot /mnt update-initramfs -u update-grub reboot

No luck.

As additional information (in case it's useful):

  • The computer appears to recognize the NVMe hard drive as a bootable device.
  • However, the NVMe drive is totally non-visible/not recognized if I boot to a live disk. I cannot edit the drive from this XPS laptop, even from a live USB disk. To edit the disk, I have to move it to another machine and then boot live.
  • My thought was to just re-install Ubuntu, but, again, the NVMe drive doesn't show up as an available drive.

When I boot straight from the NVMe on the laptop, I do get the UBUNTU splash screen. So the computer defintely recognizes the NVMe as a bootable drive.

Why wouldn't I be able to see it from a live disk?

This is what makes me think some kind of bios change has occurred that's causing havoc.

I do believe the bios is the most up-to-date version (updated it a few weeks ago). I restored the bios to default settings just in case that might help, but no dice. I checked through the available bios tweaks, but can't see what among them could possibly be causing this.

Something to do with RAM settings? Or maybe I need to reseat the RAM? I don't think so, since I can boot to a live disk. Seems the NVMe drive isn't getting along with Ubuntu.

Another reason I don't think there's actually an fstab issue: I made no change to the data on the drive. I didn't run any updates, nada. I just disassembled some hardware that caused the CMOS to clear/reset. Hence my thinking this has something to do with a bios setting.

I could definitely use some help!

Thanks in advance.

K.O.

1 Answer 1

16

Problem was indeed in the BIOS settings.

System Configuration --> SATA Operation Changed RAID to AHCI.

Bingo.

5
  • That's it!! Thank you! Worked for me with a Dell Latitude 5491.
    – J. Doe
    Nov 14, 2018 at 9:47
  • Same issue on the 5490 as well.
    – kasperd
    Jan 3, 2019 at 13:26
  • Same issue and fix for a 2020 xps Aug 15, 2020 at 7:36
  • Same issue and fix for 2020 xps 9300. Possibly caused by shutting/opening laptop somehow briefly disconnecting something
    – Idiot Tom
    Feb 22, 2021 at 22:03
  • Worked on a Dell XPS 13 7390, running Ubuntu 20.04.3 LTS. Apparently it switched to RAID upon very low power, by itself (well there was a yellow, Support Assist warning screen I had to click "Continue" through, but still). Running Ubuntu from a flash drive on the machine didn't even show any other drives on it so I was really worried but this fixed everything perfectly.
    – zulu
    Sep 28, 2021 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.