1

I downloaded libva 2.1 and intel-vaapi-driver 2.1 I compiled and "make install" and the libs were installed in /usr/local/lib and /usr/local/lib/dri.

But when I run "vainfo", it shows the old version and not the new 2.1 version. What did I do wrong?

2

I had to use ./configure --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu

2
  • You can accept your own answer as the solution. – mchid Aug 11 '18 at 19:41
  • can you explain where to do ./configure --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu, i'm noob. thanks – Nicolas Molano Mar 29 '20 at 14:05
0

While user372194 answer fixed their problem, for others Intel have a detailed installation instructions for both the libva and the libva-utils for Ubuntu 16.4, https://software.intel.com/content/www/us/en/develop/articles/build-and-debug-open-source-media-stack.html.

Step 7 from the link for simplicity.

cd $WORKING_DIR
git clone https://github.com/intel/libva.git
git clone https://github.com/intel/libva-utils.git
cd $WORKING_DIR/libva
git checkout <libva commit id>
./autogen.sh --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu
make -j4
sudo make install
cd $WORKING_DIR/libva-utils
git checkout <libva-utils commit id>
./autogen.sh --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu
make -j4
sudo make install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy