I am running Ubuntu 16.04 LTS bash on Windows 10. When I have installed a command line music player, it couldn't play any track - Error: unable to play audio.

The command aplay -l shows aplay: device_list268: no soundcards found. So it looks like I need to install the sound modules. How can I do it? I have tried this:

$ sudo apt-get install linux-restricted-modules-uname -r linux-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-restricted-modules-4.4.0-43-Microsoft
E: Couldn't find any package by glob 'linux-restricted-modules-4.4.0-43-Microsoft'
E: Couldn't find any package by regex 'linux-restricted-modules-4.4.0-43-Microsoft'

Also, when running the command lspci -nnk | grep -A3 -Fe '[0403]' it shows the following:

pcilib: Cannot open /proc/bus/pci
lspci: Cannot find any working access method.
  • I have done everything you said but still not working
    – Helio
    Apr 26, 2018 at 20:45
  • 1
    WSL is no full Linux system and doesn't allow full hardware access. Thus it doesn't even have a kernel that would allow hardware access (via loadable modules or otherwise). It may be possible to get this to work but not how one would do it in a stand-alone Ubuntu installation, which means your question is off topic here on Ask Ubuntu. You may have more lock over on Super User. Apr 27, 2018 at 12:52
  • Please repost this question at Super User.
    – karel
    Apr 27, 2018 at 21:49
  • This question is cross-posted as of now (superuser.com/q/1317998/84807) and getting different answers…
    – Melebius
    May 10, 2018 at 6:54
  • 1
    I'm voting to close this question as off-topic because others feel it is off topic, and the poster has cross-posted to superuser.com/q/1317998/84807 . I am confused that we have WSL tag, with no mention of it not being on-topic, and would like clarification if there is any.
    – earthmeLon
    May 12, 2018 at 19:40

1 Answer 1


The dependency in futex is fixed in Skip-Ahead builds which only leaves actual hardware support.

Installing Xrdp (apt install xrdp), starting the service (sudo service xrdp start), and then mstsc in the Run line with assigned port from xrdp (127.0.0.X:port#) will likely get you running a near-full desktop experience that will include sound (you get most of everything else in Fall Creator's Update and up to start with).

So running PulseAudio is very much possible. Again the only caveat is you need to be on Skip-Ahead Insider builds. There may be ways to get sound working outside of this method but I don't know them.

Not the answer you're looking for? Browse other questions tagged .