7

After I upgrade Kubuntu from 17.10 to 18.04, and restarted it, all I'm seeing is my mouse cursor, which responds to my movements, and that's pretty much it. I tried to see if I can start up sddm, but that failed.

I got to login by installing slick-greeter and use that instead.

After logging in, the message says:

Plasma is unable to start as it could not correctly use OpenGL 2. Please check that your graphics drivers are set up correctly.

I checked the environment variable $DISPLAY, but it seems to be unset.

I tried reinstalling plasma-desktop, sddm, mesa drivers, xorg, xserver-xorg*intel, kde*, kwin, and nvidia-340 drivers.

My laptop is a Lenovo Z40 with NVIDIA GT820m (currently disabled and using Intel HD Graphics).

Update: kinda fixed it

I'm not gonna mark this as a solution because I prefer to use Intel graphics (better battery life), but I uninstalled nvidia-340, and installed nvidia-384, and ran prime-select nvidia. That fixed it, but I'm hoping I can run this with Intel graphics. Another reason why I stuck with Intel Graphics for so long is because of the weird sleep bug where the laptop would wake up but the screen stays blank, but it seems to be fixed now.

I did post the bug about the problem on Launchpad and hopefully someone can let me know what was missing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.