9

This question already has an answer here:

It seems that neither winsub or woeusb are installable, except from source but I don't want to go down that rabbit hole, on Ubuntu 18.04. So what is the normal way of making the simplest thing - a bootable Windows USB?

marked as duplicate by Zanna, David Foerster, eballeste, Elder Geek, George Udosen May 8 '18 at 12:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    Some of the answers there don't apply to 18.04 unfortunately which is why I asked it again. – Alex Botev Apr 26 '18 at 5:55
  • @AlexBotev: In that case please refer to the answers that apply to 18.04 instead. Unless all answers are outdated I don't see a need for a new question. – David Foerster May 4 '18 at 7:50
  • Well, the winusb and other similar programs do not run on 18.04. I tried the answer given below but that does not seem to make a bootable USB stick either. So at this stage, I'm yet to see an answer that actually works in 18.04? – Alex Botev May 6 '18 at 17:23
  • 1
    mkusb works in 18.04 LTS. See this link, mkusb-nox and mkusb version 12 can create Windows install drives – sudodus May 7 '18 at 14:07
  • @sudodus I got this error at the end: Bootloader: Installing for i386-pc platform. grub-install: error: cannot find a GRUB drive for /dev/sda1. Check your device.map. mkcmd_runcmd: mk_msdos:error grub-install:error. Failed. p_clean: clean if necessary and return clean if necessary and quit – Alex Botev May 11 '18 at 8:05
10

First find your usb device name:

lsblk

you get something like

NAME         MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
sr0           11:0    1 1024M  0 rom  
sda           179:0   0 4.2G  0 disk 
├─sda1  1      79:1   0 3.8G   0 part /home/user/blabla

based on the sizes your USB disk we are assuming your USB is sdX in this case sda so /dev/sda
replace this with yours

unmounted the usb device.

then put an mbr table on it (all info on it would be lost):

sudo parted /dev/sdX mklabel  msdos

then create a brand new partition on the device:

sudo cfdisk /dev/sdX

choose New enter the appropriate value and hit enter then select primary followed by Write and type yes to create the partition

lets check the partitions again to be sure:

lsblk

format the partition to the appropriate format:

sudo mkfs.fat -F32  /dev/sdXY

where y is a number

mount the partition:

sudo mount /dev/sdXY /mnt

now let us extract the windows iso unto the usb:

sudo apt install p7zip-full
sudo 7z x /path/to/windowsfile.iso -o/mnt

after extraction unmount the partion:

sudo umount  /mnt

you have created the bootable disk, just reboot and use

  • I'll try it tomorrow and if it works would happily mark it as an answer. – Alex Botev Apr 26 '18 at 5:56
  • This worked for me on 18.04. I tried several suggestions before this, and none of them worked. – Nocturno May 12 '18 at 4:55
  • Can confirm, this method works. – Ilyas Deckers Aug 13 '18 at 10:47
  • It won't work with some windows ISO files because they contain large files (greater then 4GB). Probably using NTFS as fs would work. – Elias Soares Jan 10 at 16:06
0

If you need this now, you can download repo and run script in src/, like

sudo ./woeusb -d ../../Downloads/Win10_1803_EnglishInternational_x64.iso /dev/sdX

Not the answer you're looking for? Browse other questions tagged or ask your own question.