26

I have a Lenovo Yoga 910-13IKB. I was running Ubuntu 17.10 with no issues. I upgraded to 18.04 LTS and now my right-click on my touchpad does not register. I can only left-click.

I already tried the steps listed here, but they did not fix the issue.

Does anyone know how to fix this?

Thanks.

36
  1. Install gnome-tweak-tool
  2. open gnome-tweaks
  3. go to Keyboard & Mouse
  4. under Mouse Click Emulation, select Area.
  5. Reboot.
| improve this answer | |
  • Wonder how to open gnome-tweaks? Please guide. – MYaseen208 Apr 27 '18 at 21:03
  • If you don't want too use the terminal command line you can install search for "gnome tweaks" in Ubuntu Software. Once installed, open the applications menu and search for "Tweaks". – Reed Hedges May 13 '18 at 13:07
  • any idea why "Fingers" stop working after Suspend? – Tosho Aug 1 '18 at 12:59
  • @Tosho, I think it's because "fingers" mode is used for screen scrolling. – 23W Nov 18 '18 at 9:15
  • The "area" option works great on my Lenovo ideapad 330S-15IKB with Ubuntu 18.10. – Andrew Jan 28 '19 at 3:53
5

Install gnome-tweak-tool by typing:

sudo apt-get install gnome-tweak-tool

Write gnome-tweaks in terminal and press Enter. This will open gnome-tweaks. Under Keyboard & Mouse option, go to Mouse Click Emulation. There are three options there. Choose Area.

| improve this answer | |
4

In my case the issue was with my new lenovo ideapad laptop 330 for which right click will work when you press it with 2 fingers.

Might be case for someone else also so added as an answer.

| improve this answer | |
  • Thanks, your hint also worked for a Lenovo Yoga 11e. Might be a Lenovo thing. – Manu Apr 21 at 19:02
0

Maybe its new feature provide ubuntu 18. I install the

gnome-tweak-tools

and there are 3 options for Mouse Emulations. Finger, Area, and Disabled. Here the explanation

  • Finger: use 2 fingers for right click
  • Area: user right buttons for right click
  • Disable: disable touchpad

By default its set as Fingers, so you can use pointer and middle finger at once for right click

| improve this answer | |
0

The answer from Umar Soleh is excellent. This answer is just to point out an alternative which is a bit more complex, but more comprehensive because you have access to additional settings that Tweaks does not expose.

1) Install Dconf-Editor. From the Terminal:

apt-get update
apt-get install dconf-editor -y

2) Open Dconf Editor and accept the warning to be careful!

3) Find touchpad settings at /org/gnome/desktop/peripherals/touchpad

4) Select click-method; turn off Use default value; set Custom value to areas or fingers [Umar suggested fingers which for me feels the most natural]

You may be interested in other settings in this section (along with my personal recommendations):

* send-events: Set to `disabled-on-external-mouse`
* tap-and-drag: Disable (an annoying feature!)
* two-finger-scrolling-enabled: Enable (the default)
| improve this answer | |
0

Mine is Lenovo G510 Laptop.

I did tried to follow above answers but my external mouse was also not working to set the options.

So, I opened Mouse Controls and Checked and Unchecked the Left handed mouse option.

enter image description here

Restarted the laptop and it started working.

P.S. My Keyboard is working.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.