1

I have a Toshiba Satellite laptop with i5-5200U and integrated graphics running xubuntu 16.04.4 LTS (along with windows10 in a dual-boot setup). It has been working like a charm for more than a year, until a few weeks ago when the kernel was upgraded to 4.4.0-119-generic, and subsequently to 4.4.0-121.

Now it fails to boot. Grub starts fine, but when I select Ubuntu, it only says "Loading Linux 4.4.0-119-generic" and then "Loading initial ramdisk ..." and after that it just hangs forever with these two lines in a black screen. I've tried booting it in recovery mode but the problem persists. And the same happens with the newer 4.4.0-121 version.

However, with kernel version 4.4.0-116 it works perfectly. Any ideas what has changed since kernel 4.4.0-116 to cause this black screen problem? There are similar(ish) problems described here, but none of the solutions worked for me.

(Windows boots just fine, but I rarely use it.)

Edit: some links to similar questions were requested, but I didn't originally post them because none of them actually described a similar problem.

This one came pretty close, but didn't help:

Ubuntu 16.04 won't start with linux-image-4.4.0-119-generic

Here are a few more with similar symptoms.

Kernel 4.4.0-109-generic fails to boot but 4.4.0-104-generic works fine Lenovo fails to boot 4.4.0-109 Cannot boot ubuntu 16.04.3 with kernel version greater than 4.4.0-89 Ubuntu 16.04.1 LTS with kernel 4.4.0-34 does not boot after upgrading

1

So, no help from here. Fortunately this was not a life-threatening situation and I was able to boot the machine using 4.4.0.116. But the real solution was to upgrade the whole OS to 18.04 LTS. But it would have been nice to know what caused this unexpected failure.

But case closed - the answer is to upgrade to the next LTS version.

1

kernel 4.4.0-122 works fine again, until that was out I continued using 4.4.0-116. As for you 119 and 121 didn't boot for me.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.