Whenever I try to update using apt-get update it stuck at

0% [Waiting for headers]

I tried with my phone hotspot, on that it works fine but while I am using the Wi-Fi connection of my ISP it stuck. I am able to open websites in a browser, and my internet connection is totally fine.

I tried changing the server to download from and selected 'main server' and rebooted but it is not working, still stuck at

0% [Waiting for headers]

How can I fix this?


2 Answers 2


I removed the Google Chrome update from update manager > other software. And it works fine. What I found is may be the Google server takes a lot of time through my isp so I feel it's better to upgrade chrome manually.


Run the following

sudo nano /etc/gai.conf

Scroll with arrow keys down to where it says:

#precedence ::ffff:0:0/96  100

remove the comment (#) and save it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.