0

I've got a bit of a problem on my computer since the entry for lubuntu decided to vanish for some reason. I'm running lubuntu 17.10.1 on a Asus 1011PX. I'm thinking I could just change one of the entries so it boots lubuntu instead of memtest or ipxe. Lubuntu is installed on sda1, no encryption if that helps. I did update recently before this happened so that might have something to do with it.

  • 1
    Have tried sudo update-grub and reboot? Or is it impossible to boot Ubuntu or some (other) community flavour? – sudodus Apr 24 '18 at 12:10
0

If you really want to edit one of the existing entries, you can follow this askubuntu question for help. It also explains how to add a new entry.

However, I would recommend figuring out why your grub config was recreated without the lubuntu entry. Use sudo grub-mkconfig -o /boot/grub/grub.cfg.new to find out what entries are currently detected. The file /boot/grub/grub.cfg.new will then contain the configuration as detected. If you are happy with the configuration, move it to /boot/grub/grub.cfg for the changes to take effect.

Ubuntu provides the command sudo update-grub if you simply want to regenerate your grub configuration.

If you are currently unable to boot into lubuntu or another linux, follow this askubuntu answer to repair grub entirely, including rewriting the MBR.

| improve this answer | |
  • I can't boot into lubuntu on the hdd and i've only got slitaz 4 on a usb(it can't recognize ext4 filesystems and a lot of the tools on it are out-dated. It says something about invalid arguement whenever i try to mount it). I tried getting the boot repair disk but sourceforge doesn't like the version of firefox slitaz has. Again, outdated. The modern firefox refuses to start on this(something about XPCOM) and i only got a 1g of storage since slitaz loads everything in ram. I tried to dd a ubuntu live iso on a usb but it just shows a blinking screen everytime i try to boot it. – Silentstorm Apr 25 '18 at 4:01
  • Oh and i tried compiling wine from source(to get yumi to work) and that failed. The wine version in slitaz is version 1. That obviously didn't work. – Silentstorm Apr 25 '18 at 4:04
  • I got past this by using a web proxy then i got that to go to sourceforge and finally start downloading the boot repair disk. Then booted off the usb, waited a couple minutes(grub needed to reinstalled) and it boots normally. Now my network decided to go down(dns works but a ip address dosen't). I'll post a new question on that. – Silentstorm Apr 27 '18 at 7:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.