3

Problem description

It all started when I tried to install texlive 2016 following this post. I added a PPA as follows:

sudo add-apt-repository ppa:jonathonf/texlive

and then installed texlive-full. Unfortunately the installation crashed and then I decided to remove the whole package and reinstall it.

I first tried to remove texlive-full using apt-get remove, but I get the following error:

$ sudo apt-get remove texlive-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'texlive-full' is not installed, so not removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 dvipng : Depends: texlive-base-bin
 feynmf : Depends: texlive-latex-base but it is not going to be installed
          Depends: texlive-font-utils but it is not going to be installed
          Depends: texlive-extra-utils but it is not going to be installed
 fragmaster : Depends: texlive-base-bin
              Depends: texlive-latex-base but it is not going to be installed
              Depends: texlive-extra-utils but it is not going to be installed
              Depends: texlive-font-utils but it is not going to be installed
 kile : Depends: texlive-latex-base but it is not going to be installed
        Recommends: texlive but it is not going to be installed
 latex-beamer : Depends: texlive-latex-base but it is not going to be installed
 latexmk : Depends: texlive-latex-base but it is not going to be installed
 prosper : Depends: texlive-latex-base but it is not going to be installed
 tex4ht-common : Depends: texlive-base-bin
                 Recommends: tex4ht but it is not going to be installed
 texlive-base : Depends: luatex (>= 0.70.1) but it is not going to be installed
                Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 texlive-latex-extra : Depends: luatex but it is not going to be installed
                       Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
                       Recommends: texlive-latex-extra-doc but it is not going to be installed
 texlive-latex-recommended : Depends: texlive-latex-base (>= 2013.20130512) but it is not going to be installed
                             Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 texlive-luatex : Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
                  Depends: luatex (>= 0.70.1) but it is not going to be installed
 texlive-math-extra : Depends: texlive-latex-base (>= 2013.20130512) but it is not going to be installed
                      Depends: texlive-fonts-recommended (>= 2013.20130512) but it is not going to be installed
                      Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 texlive-metapost : Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 texlive-pictures : Depends: luatex but it is not going to be installed
                    Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 texlive-pstricks : Depends: texlive-generic-recommended (>= 2013.20130512) but it is not going to be installed
                    Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
                    Recommends: texlive-font-utils but it is not going to be installed
                    Recommends: texlive-extra-utils but it is not going to be installed
 texlive-science : Depends: texlive-latex-base (>= 2013.20130512) but it is not going to be installed
                   Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 texlive-xetex : Depends: texlive-latex-base (>= 2013.20130512) but it is not going to be installed
                 Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 tipa : Depends: texlive-latex-base but it is not going to be installed
        Depends: texlive-base-bin
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I tried 'apt-get -f install, but this is what I get:

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  luatex texlive-binaries texlive-extra-utils texlive-font-utils
  texlive-fonts-recommended texlive-fonts-recommended-doc
  texlive-generic-recommended texlive-latex-base
The following packages will be REMOVED:
  context
The following NEW packages will be installed:
  luatex texlive-binaries texlive-extra-utils texlive-font-utils
  texlive-fonts-recommended texlive-fonts-recommended-doc
  texlive-generic-recommended texlive-latex-base
0 upgraded, 8 newly installed, 1 to remove and 20 not upgraded.
1 not fully installed or removed.
Need to get 0 B/30,2 MB of archives.
After this operation, 9.608 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 1326901 files and directories currently installed.)
Removing context (2016.05.17.20160523-1~ubuntu14.04.1york0) ...
unknown option: format
dpkg: error processing package context (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 context
E: Sub-process /usr/bin/dpkg returned an error code (1)

Similarly, sudo apt-get install --reinstall texlive-full fails with message E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

After all this failed, I tried:

sudo rm /var/lib/dpkg/info/texlive-*
sudo dpkg --configure -a
sudo apt-get update
sudo apt-get install textlive-full

But I still get the following error:

$ sudo apt-get install texlive-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 dvipng : Depends: texlive-base-bin
 feynmf : Depends: texlive-latex-base but it is not going to be installed
      Depends: texlive-font-utils but it is not going to be installed
      Depends: texlive-extra-utils but it is not going to be installed
 fragmaster : Depends: texlive-base-bin
          Depends: texlive-latex-base but it is not going to be installed
          Depends: texlive-extra-utils but it is not going to be installed
          Depends: texlive-font-utils but it is not going to be installed
 kile : Depends: texlive-latex-base but it is not going to be installed
    Recommends: texlive but it is not going to be installed
 latex-beamer : Depends: texlive-latex-base but it is not going to be installed
 latexmk : Depends: texlive-latex-base but it is not going to be installed
 prosper : Depends: texlive-latex-base but it is not going to be installed
 tex4ht-common : Depends: texlive-base-bin
             Recommends: tex4ht but it is not going to be installed
 texlive-base : Depends: luatex (>= 0.70.1) but it is not going to be installed
            Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 texlive-full : Depends: texlive-lang-polish (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-generic-extra (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-indic (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-spanish (>= 2013.20130512) but it is not going to be installed
            Depends: latex-sanskrit but it is not going to be installed
            Depends: texlive-omega (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-cyrillic (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-humanities-doc (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-english (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-latex-extra-doc (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-european (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-publishers-doc (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-african (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-portuguese (>= 2013.20130512) but it is not going to be installed
            Depends: tex4ht (>= 20051214) but it is not going to be installed
            Depends: texlive-fonts-extra (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-fonts-recommended-doc (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-italian (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-extra-utils (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-bibtex-extra (>= 2013.20130512) but it is not going to be installed
            Depends: latex-cjk-all (>= 4.6.0+cvs20060714-2) but it is not going to be installed
            Depends: texlive-latex-base (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-font-utils (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-fonts-recommended (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-french (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-german (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-arabic (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-fonts-extra-doc (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-plain-extra (>= 2013.20130512) but it is not going to be installed
            Depends: cm-super (>= 0.3.3-3) but it is not going to be installed
            Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-music (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-generic-recommended (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-formats-extra (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-humanities (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-publishers (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-games (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-greek (>= 2013.20130512) but it is not going to be installed
            Depends: context but it is not going to be installed
            Depends: lcdf-typetools but it is not going to be installed
            Depends: texlive-lang-czechslovak (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-cjk (>= 2013.20130512) but it is not going to be installed
            Depends: texlive-lang-other (>= 2013.20130512) but it is not going to be installed
 texlive-latex-extra : Depends: luatex but it is not going to be installed
                       Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
                       Recommends: texlive-latex-extra-doc but it is not going to be installed
 texlive-latex-recommended : Depends: texlive-latex-base (>= 2013.20130512) but it is not going to be installed
                             Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 texlive-luatex : Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
                  Depends: luatex (>= 0.70.1) but it is not going to be installed
 texlive-math-extra : Depends: texlive-latex-base (>= 2013.20130512) but it is not going to be installed
                      Depends: texlive-fonts-recommended (>= 2013.20130512) but it is not going to be installed
                      Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 texlive-metapost : Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 texlive-pictures : Depends: luatex but it is not going to be installed
                    Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 texlive-pstricks : Depends: texlive-generic-recommended (>= 2013.20130512) but it is not going to be installed
                    Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
                    Recommends: texlive-font-utils but it is not going to be installed
                    Recommends: texlive-extra-utils but it is not going to be installed
 texlive-science : Depends: texlive-latex-base (>= 2013.20130512) but it is not going to be installed
                   Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 texlive-xetex : Depends: texlive-latex-base (>= 2013.20130512) but it is not going to be installed
                 Depends: texlive-binaries (>= 2013.20130512) but it is not going to be installed
 tipa : Depends: texlive-latex-base but it is not going to be installed
        Depends: texlive-base-bin
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I'm using Ubuntu 14.04 LTS.

Additional problems

The problem now is that I cannot install anything. For example:

$ sudo apt-get install travis
[sudo] password for chung: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  cp2k gnuplot pymol grace
The following packages will be REMOVED:
  context
The following NEW packages will be installed:
  travis
0 upgraded, 1 newly installed, 1 to remove and 36 not upgraded.
1 not fully installed or removed.
Need to get 793 kB of archives.
After this operation, 66,0 MB disk space will be freed.
Do you want to continue? [Y/n] Y
Get:1 http://ftp.belnet.be/ubuntu.com/ubuntu/ trusty/universe travis amd64 140117-1 [793 kB]
Fetched 793 kB in 1s (452 kB/s) 
dpkg: warning: files list file for package 'texlive-science-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-science' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-metapost' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-latex-extra' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-latex-base-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-math-extra' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-pstricks' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-latex-recommended' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-latex-recommended-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-pictures-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-pictures' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-pstricks-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-luatex' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-metapost-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-base' missing; assuming package has no files currently installed
(Reading database ... 1349546 files and directories currently installed.)
Removing context (2016.05.17.20160523-1~ubuntu14.04.1york0) ...
unknown option: format
dpkg: error processing package context (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 context
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried this solution

Part 1

I ran

sudo apt-get clean
sudo apt-get autoclean
sudo apt-get -f install

The last command now gives the following messages:

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  context
0 upgraded, 0 newly installed, 1 to remove and 41 not upgraded.
1 not fully installed or removed.
After this operation, 68,2 MB disk space will be freed.
Do you want to continue? [Y/n] 
dpkg: warning: files list file for package 'texlive-metapost' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-latex-extra' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-latex-base-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-math-extra' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-pstricks' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-latex-recommended' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-latex-recommended-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-pictures-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-pictures' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-pstricks-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-luatex' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-metapost-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-base' missing; assuming package has no files currently installed
(Reading database ... 1349546 files and directories currently installed.)
Removing context (2016.05.17.20160523-1~ubuntu14.04.1york0) ...
unknown option: format
dpkg: error processing package context (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 context
E: Sub-process /usr/bin/dpkg returned an error code (1)

I then ran sudo dpkg --configure -a and again sudo apt -f install, but nothing changed and dist-upgrade replays the above errors.

I tried sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade which exited with the same error messages as above.

Part 2

I could not install ppa-purge using apt, so I installed it manually by running:

mkdir ppa-purge && cd ppa-purge && wget http://mirror.pnl.gov/ubuntu/pool/universe/p/ppa-purge/ppa-purge_0.2.8+bzr56_all.deb && wget http://mirror.pnl.gov/ubuntu//pool/main/a/aptitude/aptitude_0.6.6-1ubuntu1_i386.deb && sudo dpkg -i ./*.deb

Then I removed the PPA that caused the trouble in the first place. I ran:

sudo apt-get autoremove --purge texlive*

and I got these error messages:

The following packages have unmet dependencies:
 aptitude:i386 : Depends: libapt-pkg4.12:i386 (>= 0.8.16~exp12ubuntu6) but it is not going to be installed
                 Depends: libboost-iostreams1.46.1:i386 (>= 1.46.1-1) but it is not installable
                 Depends: libcwidget3:i386 but it is not going to be installed
                 Depends: libept1.4.12:i386 but it is not going to be installed
                 Depends: libsigc++-2.0-0c2a:i386 (>= 2.0.2) but it is not going to be installed
                 Depends: libxapian22:i386 but it is not going to be installed
                 Recommends: apt-xapian-index:i386 but it is not installable
                 Recommends: libparse-debianchangelog-perl:i386 but it is not installable
 dvipng : Depends: texlive-base-bin
 feynmf : Depends: texlive-latex-base but it is not going to be installed
          Depends: texlive-font-utils but it is not going to be installed
          Depends: texlive-extra-utils but it is not going to be installed
 fragmaster : Depends: texlive-base-bin
              Depends: texlive-latex-base but it is not going to be installed
              Depends: texlive-latex-recommended but it is not going to be installed
              Depends: texlive-extra-utils but it is not going to be installed
              Depends: texlive-font-utils but it is not going to be installed
 kile : Depends: texlive-latex-base but it is not going to be installed
        Recommends: texlive but it is not going to be installed
 latex-beamer : Depends: texlive-latex-base but it is not going to be installed
 latex-xcolor : Depends: texlive-latex-recommended but it is not going to be installed
 latexmk : Depends: texlive-latex-base but it is not going to be installed
 pgf : Depends: texlive-latex-recommended but it is not going to be installed
 ppa-purge : Depends: aptitude but it is not going to be installed
 prosper : Depends: texlive-latex-base but it is not going to be installed
           Depends: texlive-pstricks but it is not going to be installed
           Depends: texlive-latex-recommended but it is not going to be installed
 purifyeps : Depends: texlive-metapost but it is not going to be installed
 tex4ht-common : Depends: texlive-base-bin
                 Recommends: tex4ht but it is not going to be installed
 tipa : Depends: texlive-latex-base but it is not going to be installed
        Depends: texlive-base-bin
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Then:

sudo add-apt-repository --remove ppa:jonathonf/texlive
sudo apt-get autoclean

these commands did not give any errors.

However, the above procedure did not resolve the problem. Here is the output of sudo apt -f install:

$ sudo apt -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  aptitude aptitude-common libcwidget3 libept1.4.12
Suggested packages:
  aptitude-doc-en aptitude-doc tasksel debtags libcwidget-dev
The following packages will be REMOVED:
  aptitude:i386 context
The following NEW packages will be installed:
  aptitude aptitude-common libcwidget3 libept1.4.12
0 upgraded, 4 newly installed, 2 to remove and 42 not upgraded.
3 not fully installed or removed.
Need to get 2.520 kB of archives.
After this operation, 64,8 MB disk space will be freed.
Do you want to continue? [Y/n] 
Get:1 http://ftp.belnet.be/ubuntu.com/ubuntu/ trusty/main aptitude-common all 0.6.8.2-1ubuntu4 [700 kB]
Get:2 http://ftp.belnet.be/ubuntu.com/ubuntu/ trusty/main libcwidget3 amd64 0.5.16-3.5ubuntu1 [307 kB]
Get:3 http://ftp.belnet.be/ubuntu.com/ubuntu/ trusty/main libept1.4.12 amd64 1.0.12 [142 kB]
Get:4 http://ftp.belnet.be/ubuntu.com/ubuntu/ trusty/main aptitude amd64 0.6.8.2-1ubuntu4 [1.371 kB]
Fetched 2.520 kB in 1s (1.752 kB/s) 
dpkg: warning: files list file for package 'texlive-metapost' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-latex-extra' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-latex-base-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-math-extra' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-pstricks' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-latex-recommended' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-latex-recommended-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-pictures-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-pictures' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-pstricks-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-luatex' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-metapost-doc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'texlive-base' missing; assuming package has no files currently installed
(Reading database ... 1349665 files and directories currently installed.)
Removing aptitude (0.6.6-1ubuntu1) ...
Removing context (2016.05.17.20160523-1~ubuntu14.04.1york0) ...
unknown option: format
dpkg: error processing package context (--remove):
 subprocess installed post-removal script returned error exit status 1
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Errors were encountered while processing:
 context
E: Sub-process /usr/bin/dpkg returned an error code (1)

My apt sources

This is the content of /etc/apt/sources.list and these are my PPAs (output of cat /etc/apt/sources.list.d/*)

4
  • Which version of Ubuntu are you running? Apr 24 '18 at 11:40
  • @L.D.James I updated my question - I'm using Ubuntu 14.04. Apr 24 '18 at 11:42
  • What is the output of cat /etc/lsb-release | egrep LTS? Apr 24 '18 at 12:41
  • @L.D.James Without egrep it gives: DISTRIB_ID=Ubuntu DISTRIB_RELEASE=14.04 DISTRIB_CODENAME=trusty DISTRIB_DESCRIPTION="Ubuntu 14.04.5 LTS" Apr 24 '18 at 15:53
2
+50

Just had a headache myself today with having to fix a broken kernel 4.14.36 and 4.14.37 which could not be removed due to symbolic link errors.

Referring to this Q&A: Remove broken PPA package with unknown option, but following my "cheat" method, edit the file /var/lib/dpkg/info/context.postrm and after the line:

#!/bin/sh

insert the line

exit 0

Save the file and use:

sudo apt install -f

It should run without any errors now.

2
  • Thank you very much. This fixed the problem. I ran sudo apt install -f and then removed exit 0 from context.postrm. By the way, what was the problem exactly? What does this context.postrm do? Apr 30 '18 at 7:46
  • I don't have a context.postrm to look at. In my case it was a failing script for kernel 4.14.36 and 4.14.37 that crashed during install due to missing symbolic links. During removal the problem script was trying to confirm something existed to remove, wasn't finding it (because it was never installed) and exiting with 127. Hope that makes sense :) Apr 30 '18 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.