0

I mounted a folder under /media/datasets, owner and group group are specified as root:

$ ll /media/
drwxrwxrwx 31 root root  4,0K Apr 19 19:55 datasets

Now I want to set the sticky bit to that directory to prevent the users from deleting each others folders, so the rights should look like this:

drwxrwxrwt 

However when I do

sudo chmod o+t /media/datasets

It says

chmod: changing permissions of ‘/media/datasets’: Operation not permitted

I can execute the command above on folders inside /media/datasets but not on /media/datasets itself. I'm not sure why. Anyone an idea how to fix this?

Not sure if this is important but the datasets folder is located on a synology fileserver (NAS) and is mounted on multiple machines simultaneously.

  • Might the underlying file system of your mounted folder possibly not support sticky bits or Unix permissions in general? Do you know what type it is? – Byte Commander Apr 24 '18 at 12:11
  • Permissions should be fine, since I can set permissions for subfolders . I checked the synology NAS settings. It says "Squash: Map all users to admin: Assigns access privileges to all users of NFS client equivalent to the admin user access privileges on your system." Maybe that is a problem, I will try to change that setting once the NAS is being maintained and report the result here – mcExchange Apr 24 '18 at 12:39
  • Have you tried sudo chmod o+t /media/datasets before mounting the file system here? – pim Apr 24 '18 at 12:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.