1

I am trying to get gmediaserver (v0.13.0-8) to serve all of my mp3s. Right now it sees only a portion of them. I noticed that the "file" command produces different results for the working files than the non-working ones. On a working file I get the following result:

$ file 01\ -\ 2112.mp3 
01 - 2112.mp3: Audio file with ID3 version 2.3.0, contains: MPEG ADTS, layer III, v1, 128 kbps, 44.1 kHz, JntStereo

on a non-working file I get the following result:

$ file 01\ -\ Prowler.mp3 
01 - Prowler.mp3: Audio file with ID3 version 2.3.0

I loaded the non-working file into audacity and exported it into a test folder, and gmediaserver was able to properly identify it. When I run "file" on the exported file I get the following result:

$ file 01\ -\ Prowler.mp3 
01 - Prowler.mp3: Audio file with ID3 version 2.4.0, extended header, contains: MPEG ADTS, layer III, v1, 320 kbps, 44.1 kHz, JntStereo

Does anyone know what the "contains:..." portion of the data is called and if there is a magic command I can use to add this to an mp3 file?

Is this a red herring. Could it possibly be an issue with the metadata container? If so, how do I display the metadata container version used by the file?

Does the string "extended header" have anything to do with it?

If I can find a magic command to add the right data to the file, I could write a script to do it to all of the ones that are not working. If anyone would like a copy of a non-working file, feel free to PM me and I'll get it to you for testing purposes.

  • How were the non-working files created? BTW, welcome to Ask Ubuntu! – wjandrea Apr 24 '18 at 2:46
  • I'm not sure. I copied them from a friends music library, so they may have been torrented. Who knows. Thank you! I have been referencing this forum for a long time, but never had to actually ask a question until now. This is a great forum with lots of helpful and smart people. – user821447 Apr 24 '18 at 3:41
  • I've searched my music library with this pipeline: find . -name "*.mp3" -exec file {} \; | grep -v "contains". I had to stop it cause it found hundreds of songs, including some I bought online, some I ripped myself, some I edited in Audacity years ago, some with ID3 2.3.0, some with ID3 2.4.0. I can't seem to find any pattern in them. I haven't tried installing gmediaserver, but I made sure they play in Clementine. – wjandrea Apr 24 '18 at 4:24
0

I decided to not use gmediaserver. I found mediatomb and I haven't had any issues with it so far. All my music was found no problem.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.