1

Gufw turns itself off at every reboot. I've entered all the commands in terminals.... sudo systemctl enable ufw sudo systemctl start ufw and so on. This is a major security risk. Why has a firewall been provided which switches itself off? Is there another firewall which works as would be expected? Thanks, Bob

3
  • Well, there's one alternative askubuntu.com/a/7783/295286 Never tried it myself, though, so can't recommend. – Sergiy Kolodyazhnyy Apr 24 '18 at 2:08
  • 2
    I believe that with ufw you actually have to use sudo ufw enable from the command line to turn it on, and sudo ufw disable to turn it off. Also, you can check the status with sudo ufw status and you can check with the systemctl status ufw.service. – Terrance Apr 24 '18 at 2:16
  • 4
    You've got something configured wrong. ufw doesn't turn off on any of my systems. Also note: gufw is not the firewall, ufw is. gufw is just the configuration interface. – Organic Marble Apr 24 '18 at 3:44
3

Normally, there is no need to switch it on. The solution to your questions for ufw can be found here. More informations you found here. The normal behavior is if it's enabled it keeps enabled after reboot. To try another, maybe this fits your need firewalld.

And it's described in the gufw UI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.