0

Like the title says, I'm having trouble syncing music onto my phone (Samsung Note 5 running Android version 7.0) using Rhythmbox 3.3 in Ubuntu 16.04. Here's the steps I take:

  1. Open Rhythmbox
  2. Unlock my phone and plug it into my comp
  3. Accept the warning on my phone "allow acces to device data - an MTP connection will be established..."
  4. "SAMSUNG Android" pops up in Rhythmbox's devices list
  5. Set up properties for the phone using the properties button - right now I'm just trying to sync a playlist with a single song, also tried one with about 30 songs with the same results
  6. Hit the sync button, which brings up this error from Rhythmbox

"Error transferring track - could not open resource for writing"

Copying music onto the phone using the direct approach works, and the phone is able to play the tracks that are copied. The phone is NOT locked when the error occurs. Also Rhythmbox can see and play tracks from the phone while it's connected.

Also note that I've tried solutions like the ones found in posts like this: Sync Android with Rhythmbox

Copying single music tracks into the phone's music directory before syncing doesn't do anything to help the error.

Any help or suggestions are greatly appreciated!

0

I experienced the same issue using a Samsung Galaxy S7 and Rhythmbox 3.4.2 in Ubuntu 18.04.

I solutioned it by updating Rhythmbox to version 3.4.3. You can install it from an unofficial PPA (http://ubuntuhandbook.org/index.php/2019/01/rhythmbox-3-4-3-released-with-numerous-bug-fixes/).

Worked for me !

-1

With a little luck and help from a tech expert I figured out the solution to my problem.

You have to change the USB connection settings on the android phone. Try these steps:

  1. Connect your phone to the computer, make sure to allow USB data transfer if your phone asks you
  2. In your phone notifications list there should be an entry that says something like "USB for file transfer - tap for other USB options"
  3. In the list of options that follows, choose the second option "Transfer images."

I had been using the top option "Transfer files," the second option on the list says "Transfer Images" and then clarifies that only images can be transferred using that option. It is full of lies. Changing to this USB transfer mode has solved the issue. Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.