3

I am having some troubles booting into my laptop (Toshiba P75-A7200). Powering on my laptop promptly brings me to the GNU GRUB screen. Selecting the Ubuntu option (or anything from the Advanced options for Ubuntu menu) promptly drops me into the BusyBox v1.22.1 (initramfs) window, following advice from Ask ubuntu - Boot drops to a (initramfs I typed exit into the terminal hoping to get the name of the corrupted partition. Instead I get a lot of errors saying

mount: mounting /sys on /root/sys failed: No such file or directory

mount: mounting /proc on /root/proc failed: No such file or directory

/init: line 343: can't open /root/dev/console: no such file

then a whole bunch of other lines including

Kernel panic - not syncing: Attempted to kill init!

CPU: 2 PID: 1 Comm: init not tainted

There are a whole bunch of other lines I can post if necessary but I think those are the important ones. Now since the terminal won't let me type anything else I need to do a hard restart. I have managed get into the BIOS and to liveboot into ubuntu using a usb stick with latest ubuntu distribution (Ubuntu 16.04.4 LTS). I then pulled up a terminal to try and fix the superblock. I used sudo mke2fs -n /dev/sda5 to get a list of the backup superblocks on sda5 then I tried to use sudo e2fsck -b block_number /dev/sda5 to fix the superblock, replacing block_number with one of the backup superblocks listed but it gives me the following error.

e2fsck 1.42.13 (17-May-2015)

e2fsck: Bad magic number in super-block while trying to open /dev/sda5

The superblock could not be read or does not describe a valid ext2/ext3/ext4 filesystem.

After trying this with a few different blocks it occurred to me that earlier the sudo mke2fs -n /dev/sda5 command warned me that /dev/sda5 contains a crypto_LUKS file system. I told it to proceed anyways. When I first installed ubuntu I encrypted the hard drive using the build in option during installation. Could this be the reason I can't fix the superblock with one of the backups and if so how can I fix it? I haven't been able to find much information on crypto_LUKS or how to fix superblocks when using it. Some people mentioned how you have to decrypt the drive before recovering the data but at this point I'm just trying to get my computer working again, if I can't then I'll see about recovering the data and starting over when I get home. I have tried using fdisk a few times but while it hasn't really given me any errors it also didn't fix anything (that I can tell).

I have also used the sudo fdisk -l|grep Linux|grep -Ev 'swap' command which in addition to telling me that partition 2 does not start on a physical sector boundary lists sda1 and sda5, I'm pretty sure sda5 is where the issue is.

Using sudo dumpe2fs /dev/sdaX | grep superblock for sda1 gives a list of backup superblocks but if I try it with sda5 it tells me

dumpe2fs: Bad magic number in super-block while trying to open /dev/sda5

Couldn't find valid filesystem superblock

Any help and/or recommendations would be greatly appreciated, thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.