3

I'm trying to install OpenCor

When I try to launch it I got this error message :

This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: xcb.

Reinstalling the application may fix this problem.
Aborted (core dumped)

I have found lot page on internet and some post, but nothing solved my problem....

I using Ubuntu 16.04 LTS

EDIT :

I have try to :

sudo apt-get install xcb 

Which was already satified, :

xcb is already the newest version (2.4-4.3).
The following packages were automatically installed and are no longer required:
  linux-headers-4.13.0-36 linux-headers-4.13.0-36-generic
  linux-image-4.13.0-36-generic linux-image-extra-4.13.0-36-generic
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 18 not upgraded.

I tried almost everything proposed on this post and have no PPAs installed.

EDIT 2

The command : sudo apt upgrade

return :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.13.0-36 linux-headers-4.13.0-36-generic
  linux-image-4.13.0-36-generic linux-image-extra-4.13.0-36-generic
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

and still have the same problem with OpenCOR and the little script from @Fabby still do not give output at all...

12
  • What have you tried to do to fix it? Have you tried simply installing xcb sudo apt install xcb What error messages are you getting when you try to install the package? Please edit your question and give us more details.
    – Terrance
    Apr 23, 2018 at 13:29
  • yes of course, but I will edit my post
    – Dadep
    Apr 23, 2018 at 13:31
  • 1
    I am running Xubuntu 16.04. I just downloaded and I ran the OpenCOR application and it ran without a problem. Unfortunately I am unable to duplicate your issue, so all I can do is guess as to what might be causing it. So, I won't be much help there. I also didn't have to install OpenCOR, I just ran it from the OpenCOR-2018-04-23-Linux/bin folder and it ran fine. I am sorry I am not much more help.
    – Terrance
    Apr 23, 2018 at 14:33
  • @Terrance I have tried to do the same... but I've got this error message. I understand that this problem is not specific to OpenCOR, but couldn't find solution...
    – Dadep
    Apr 24, 2018 at 7:15
  • What's the output of this little script ???
    – Fabby
    Apr 26, 2018 at 19:19

1 Answer 1

2
+50

Stable OpenCOR 0.5 works on clean Ubuntu 16.04 LTS after

cd ~/Downloads
wget http://www.opencor.ws/downloads/0.5/OpenCOR-0-5-Linux.tar.gz
tar -xf OpenCOR-0-5-Linux.tar.gz
cd OpenCOR-0-5-Linux/
./OpenCOR

but shows warning on launch:

/usr/lib/x86_64-linux-gnu/libproxy.so.1: symbol _ZTTNSt7__cxx1119basic_ostringstreamIcSt11char_traitsIcESaIcEEE, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference
Failed to load module: /usr/lib/x86_64-linux-gnu/gio/modules/libgiolibproxy.so

You can remove these messages with

sudo apt-get install glib-networking

But it shows Error: illegal value in the interface:

OpenCOR 0.5 on Ubuntu Xenial

I'm not familiar with this program, so I do not known is it critical or not.

--

Also it seems that Latest snapshot version works out the box on
clean installation of Ubuntu 16.04 LTS.

You can proceed with:

cd ~/Downloads
wget http://www.opencor.ws/downloads/snapshots/2018-04-23/OpenCOR-2018-04-23-Linux.tar.gz
tar -xf OpenCOR-2018-04-23-Linux.tar.gz
cd OpenCOR-2018-04-23-Linux/
./OpenCOR

Then its GUI window was opened:

OpenCOR snapshot on 16.04 LTS

2
  • Thanks for your help, the latest snapshot version works but I still have the same problem for OpenCOR 0.5...When I do ./OpenCOR I get the error describr in my post.
    – Dadep
    May 2, 2018 at 7:08
  • I have installed HWE on my 16.04 LTS, I can confirm error about xcb with v0.5 on it. It seems that you have two options: remove HWE (downgrade xserver) or use latest snapshot.
    – N0rbert
    May 2, 2018 at 10:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .