0

I'm having trouble making the integrated Intel GPU visible to Ubuntu 16.04, the only GPU available is the discrete nvidia one. The issue is happening on 2 laptops: a new Alienware 15 R3 and an old Toshiba with GTX670m. I've found several solutions online, but none worked, usually ending up with a black screen on reboot, so I'm posting my question, hopefully someone can help. I have to admit that I'm not so handy with the command line, so bear with me, and please write very detailed instructions if the solution requires editing config files. Some info and things I tried:

  • 'sudo lspci | grep VGA' only shows the nvidia GPU: 01:00.0 VGA compatible controller: NVIDIA Corporation Device 1be0 (rev a1)

  • I checked the BIOS, and there is NO WAY to select the GPU, on both laptops

  • 'sudo prime-select intel' just creates a duplicate nvidia profile with the name 'intel'

  • there is NO 'prime' entry in nvidia-settings

  • tried using the intel graphics installation tool from https://01.org/linuxgraphics (actually obsolete now): it completes successfully, but it doesn't change a thing.

Everything indicates that the Intel GPU is effectively invisible under linux, which is frankly absurd, because both GPUs are working under Windows: the hardware is OK, it's just a configuration problem. Any help is appreciated.

EDIT 26/04/2018,

Forget the Alienware, I found out that this model (Alienware 15 R3) has a G-sync display, so Dell have hardwired it to the Nvidia GPU, G-sync being an Nvidia-only technology. So there is no way, phisically, to use the Intel GPU as the display GPU.

My question is still open, but only for the Toshiba laptop, which is a Qosmio X870-119

EDIT 24/04/2018, in reply to comments:

@Vanessa Deagan: nvidia drivers installed with 'sudo apt-get install nvidia-390'.
yes, I rebooted. Here's the commands and outputs:
$sudo prime-select intel Info: the current GL alternatives in use are: ['nvidia-390', 'nvidia-390'] Info: the current EGL alternatives in use are: ['nvidia-390', 'nvidia-390'] Info: selecting nvidia-390-prime for the intel profile update-alternatives: using /usr/lib/nvidia-390-prime/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in manual mode update-alternatives: using /usr/lib/nvidia-390-prime/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf (x86_64-linux-gnu_egl_conf) in manual mode update-alternatives: using /usr/lib/nvidia-390-prime/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in manual mode update-alternatives: using /usr/lib/nvidia-390-prime/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_EGL.conf (i386-linux-gnu_egl_conf) in manual mode $sudo prime-select query intel
after reboot:
$sudo prime-select query nvidia

@Philippe Delteil: $ nvidia-smi Tue Apr 24 15:17:48 2018
+-----------------------------------------------------------------------------+ | NVIDIA-SMI 390.48 Driver Version: 390.48 | |-------------------------------+----------------------+----------------------+ | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC | | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. | |===============================+======================+======================| | 0 GeForce GTX 108... Off | 00000000:01:00.0 On | N/A | | N/A 54C P0 39W / N/A | 225MiB / 8114MiB | 0% Default | +-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+ | Processes: GPU Memory | | GPU PID Type Process name Usage | |=============================================================================| | 0 1089 G /usr/lib/xorg/Xorg 152MiB | | 0 2219 G compiz 70MiB | +-----------------------------------------------------------------------------+

Grepping for NVIDIA returns exactly the same as grepping for VGA:
$ sudo lspci | grep NVIDIA 01:00.0 VGA compatible controller: NVIDIA Corporation Device 1be0 (rev a1)

  • After you executed sudo prime-select intel, did you reboot? – Vanessa Deagan Apr 23 '18 at 13:18
  • How did you install the Nvidia drivers? – Vanessa Deagan Apr 23 '18 at 13:20
  • what's the output of this command, nvidia-smi ? you should include the output of sudo prime-select intel. I have an Intel VGA card and a Nvidia card, doing 'sudo lscpi | grep VGA' shows only the integrated card. What happens if you run 'sudo lspci | grep NVIDIA'? – Philippe Delteil Apr 23 '18 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.