2

I searched this question through several sites and boards, but it seems no one asked this way. I know abort "Date" column in "Details view mode", but it sorting by "date created", not modified. I also looked under "view" > "adjust view properties" > "additional information", but there are same plain "date" available. I need more specific files sorting in dolphin, by their date attributes.

So, maybe you can advice me with some plugins\extension for dolphin with such functionality, or refer me to documentation about how to create this plugin, if there are no any. (I'm capable of wring small apps on C++ and pascal)

And please sorry for my English...

0
1

While the Dolphin windows is ontop (active), Click on View from the Ubuntu global menu. From there point to Sort by... then click on Date.

The Ubuntu Global menu also has a View mode option. You can select Details from there, and see the items in columns, and click on the Date tab to sort by date from that mode.

Note:

Dolphin also has menu items on it's top screen. You can change views there. The Control button also have Sort and View Mode options.

Update:

The default display in Dolphin is the Modification date of the folders and files. Changing this is not an immediate feature of Dolphin's settings. It can be done via KDE's System Settings. I can't find it in Ubuntu's system settings.

Details for changing/adding display options are described here:
Linux: Changing Date Format in Detailed Display in Dolphin File Manager

3
  • sorry, but it seems you didn't read my question body: Look at 2nd sentence in 1st paragraph -- I talking exactly about that default sorting, you are referring me in your answer. As I mentioned, this doesn't work I need to.
    – scadl
    Apr 23 '18 at 10:16
  • Sorry, I inferred that you were able to see the desired view, and the problem was sorting by that view. I addressed sorting by the various view settings. I'll add a reference to changing view settings. Apr 23 '18 at 10:30
  • I added an updated section. The date column is showing the files modification data by default. Are you saying that if you make a change of an old file and save it, the data column of that file is staying the same? On mine the date column changes. If it doesn't change, I'll try to help you to identify what you might have done to change the default behavior... or what is different in your environment from the defaults. Apr 23 '18 at 11:09
1

Thanks to @l-d-james and @dk-boose I managed to narrow down my problem.

The thing is, that problem I talking, are actually present only in ftp folders, opened in dolphin. So this is not about file manager, but about its ftp plugin, residing inside "kio" package. According to this bugtracker thread, kio 5.17 (part of xenial) has this bug, which was fixed already in version 5.18.

I wanted to stay on [K]Ubuntu 16.04.4 LTS, so I found way to update only plasma (to version 5.6.5, which contains kio 5.36.0)

So, to fix this problem (or other problems requiring kde update) you have to:

sudo add-apt-repository ppa:kubuntu-ppa/backports 
sudo apt-get update
sudo apt-get upgrade

Than reboot, and check if problem still present.
I my case everything looks an works like a charm.
(Also I got fresh new look for my kde)

Thank to everyone for helping me out!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.