0

I recently upgraded from 14.04 to 16.04, and a found a few broken dependencies. I have tried several solutions and managed to fix some of the issues, but this one keeps coming up with 13 broken packages. The output is in the pastebin below.

https://pastebin.com/Znw8xWPS

Edit 1:

I no longer receive the errors below, as I followed the instructions in the output and removed these files manually:

Ignoring /etc/texmf/texmf.d/05TeXMF.cnf during generation of texmf.cnf, please remove manually!

There were 9 other files with the same error; all were deleted. However, I am still receiving the errors that follow:

Setting up tex-common (6.04) ... Running mktexlsr. This may take some time... done. Running updmap-sys. This may take some time... updmap-sys failed. Output has been stored in /tmp/updmap.n68zJZwY

Please include this file if you report a bug.

Sometimes, not accepting conffile updates in /etc/texmf/updmap.d causes updmap-sys to fail. Please check for files with extension .dpkg-dist or .ucf-dist in this directory

No files with these extensions exist in that directory.

dpkg: error processing package tex-common (--configure): subprocess installed post-installation script returned error exit status 1

dpkg: dependency problems prevent configuration of texlive-latex-base: texlive-latex-base depends on tex-common (>= 6); however: Package tex-common is not configured yet.

The dpkg errors continue for the 13 packages in question, with full output here: https://pastebin.com/QqupKHFH.

Output file referenced above is here: https://pastebin.com/vthGdcPz

For what it's worth, and to the best of my knowledge, I don't use these packages. I installed TeX a long time ago to explore, but do not use it. Uninstalling these packages are a viable option, although repairing these is a great learning opportunity. I tried using the --syncwithtrees option on a couple of commands, to no avail; I'm not really sure where it belongs. Thanks for the feedback so far!

  • It would be easier to give you support if more of your description was included in your question. I understand that you want to include as much as possible. But you might consider adding 10 or 15 lines of your output to your question and including a pastebin link for other details that might use hundreds of lines. It takes a little more work to leave AU's page and study links. As far as a dpkg error look at the output, perform the suggested command for the resolution. The error message almost always gives a specific command for resolving the problem. – L. D. James Apr 22 '18 at 22:22
  • how did you install Tex? – Fabby Apr 22 '18 at 22:44
  • Fabby, it's been so long I don't really remember. From the command line, several years ago. I don't need it anymore, but I'm not sure how to fix the dpkg/ dependency errors. My next step may be a reinstall. – bubb May 13 '18 at 3:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.