my PS$ controller is not functioning properly or recognised within Steam. I seem to be in the minority on the pages I have looked at.

I successfully paired the controller via Bluetooth and it shows in setting as 'wireless controller'. Within Ubuntu normally, the controller only moves the cursor via the touchpad built into it.

I then startup steam and it does not recognise a controller exists (it tells me in the settings) and when I start to play a game (the only one I currently have is TF2), again only the touchpad on the controller moves the character (its look only) and the 'option' button does bring up the menu in TF2.

Basically, it's acting as a mouse only, not a controller, from what I can see.

I'm running 18.04 Bionic Beaver and from the articles I've read, support and drivers for these controllers are built into the kernel since about version 13, hence why I'm stumped.

Hope someone can help, thanks :)


Support is ostensibly native, but that doesn't mean the system couldn't use extra help I guess. I installed and ran this lovely gem that's been around for a while

Specifically, after getting pip, I ran

sudo -H pip install ds4drv
ds4drv --hidraw
| improve this answer | |
  • 1
    Thanks as well and this seemed to work a treat! Just had a very quick move around and the basics are there, just need configuring a bit. – Zero-33 May 29 '18 at 21:48
  • Hi Karl, I tried this and I'm not sure how I should connect the controller. To be precise, I have a bluetooth connection set up, but when I run ds4drv --hidraw this text appears [error][controller 1] Failed to create input device: "/dev/uinput" cannot be opened for writing [info][hidraw] Scanning for devices and nothing happens. Do you know what's going on ? Thanks – Olivier Bégassat Jan 14 '19 at 0:11
  • @OlivierBégassat Sounds like a permissions error. You could try sudo. Also, I recently had to reinstall 18.04 on my machine to fix an unrelated problem I was too lazy to dig further into, and instead of doing this I actually wound up following the answer below, after which everything worked just fine. Mayhaps you could attempt that as well if ds4drv doesn't work for you? – Cether_Skye Jan 15 '19 at 9:10

To get my steam controller working in 18.04 I had to install steam-devices.

sudo apt install steam-devices

This may solve your problem.

| improve this answer | |
  • 1
    Thanks for the advice and I installed this, but unfortunately, this hasn't solved the issue. – Zero-33 May 29 '18 at 21:45
  • 1
    Thanks a bunch! I did assume this was installed with the steam package. I had to restart Steam and reconnect the controller, it then worked instantly. – Tim Visee Jun 11 '18 at 13:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.