11

I've noticed a lot of people having similar issues with finding a driver for NETGEAR A6100 AC600 WiFi Adapter.

I've been struggling with a lot of the threads and drivers posted on github. Many of the ones listed are referencing a rtl8812au driver while I believe my particular one is a rtl8811au.

I ran the wireless info script that is floating around and these are my results https://pastebin.ubuntu.com/p/XDnGNYcKPT/

I did get this driver to make and install but it doesn't seem to do anything. https://github.com/diederikdehaas/rtl8812AU I still don't have any wireless connections popping up.

Any help on this matter would be much appreciated..

0
10

The driver you compiled doesn't cover your device at all. You can confirm it with:

modinfo 8812au | grep 9052

Where '9052' is the last part of your usb.id:

ID 0846:9052 NetGear, Inc. A6100 AC600 DB Wireless Adapter [Realtek RTL8811AU]

The command will come back blank.

Let's remove it. In the terminal, navigate to the location of the file you downloaded, for an example, Downloads:

cd ~/Downloads/rtl8812AU
sudo make uninstall
cd ..
rm -rf rtl8812AU

Now let's download a better file:

sudo apt update
sudo apt install git
git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux.git
cd rtl8812AU_8821AU_linux
make
sudo make install

Check:

modinfo rtl8812au.ko | grep 9052

The terminal should return your device ID:

alias:          usb:v0846p9052d*dc*dsc*dp*ic*isc*ip*in*

Reboot and you should be all set.

4
  • I'm finding that I get about half the download speeds compared to the ones I get on a old laptop in the same room. Any advice on why it might be running super slow? – noviceuser Apr 23 '18 at 11:46
  • Your download speed question should be the subject of a new post. If my answer above has been helpful, please accept it: askubuntu.com/tour – chili555 Apr 23 '18 at 13:10
  • 1
    The driver does not start when i restart....I am using Ubuntu 16.04 – flexxxit Oct 16 '18 at 9:14
  • 1
    I had to disable secure boot...and now it works on restart – flexxxit Oct 16 '18 at 10:19
10

The git repo recommended here doesn't seem to work with Linux kernel version >= 5.0, so this install uses a similar repo that has been updated for newer kernels. (Check your kernel version if you don't know with uname -r.) In fact, following the above guide was probably the cause of the otherwise inexplicable total system freezes I experienced. The following install procedure uses dkms (sudo apt-get install dkms), but, as the README explains (https://github.com/gnab/rtl8812au), you can also set up this driver similar to the above. Anyway, here's the install using dkms:

git clone https://github.com/gnab/rtl8812au.git
sudo dkms add ./rtl8812au
sudo dkms build 8812au/4.2.3
sudo dkms install 8812au/4.2.3

Check with: sudo dkms status

Automatically load at boot with: echo 8812au | sudo tee -a /etc/modules.

Adapted from: https://www.learningpenguin.net/2018/01/30/install-realtek-rtl8812au-wifi-driver-linux/ and the README of the repo.

4
  • This worked for me on Kali Linux 2019.4. Thank you so much! – Kale Muscarella Apr 7 '20 at 7:51
  • 4
    As of June 2020 I had to change 4.2.3 to 4.2.2 – Organic Marble Jun 23 '20 at 17:40
  • July 2020 - Works on Pop_OS! 20.04(Kernel 5.4.0-7634-generic) – Kuberchaun Jul 20 '20 at 14:42
  • Thanks, that was really helpful – fi11222 Sep 18 '20 at 11:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.