0

I have a serious problem.

Earlier today I had to make a clean install of Ubuntu 17.10 on my private computer. I'd hoped that I could easily access the (encrypted) backups I've earlier made with the Deja-dup Backup tool on my external hard drive. However, I now get the error message that the "restore failed" because there are "no backups to restore", although I do see the relevant .difftar.gpg files in Nautilus.

I've tried using the command line

duplicity restore file:///path_to_folder_contains_backups/ path_where_to_extract_it/

but get the error message:

CollectionsError: No backup chains found

Running

sudo duplicity collection-status file:/path/to/file

returns that there is 1 secondary backup chain and 1 primary backup chain with a matching signature chain. However, it also throws a gpg WARNING: "unsafe ownership on homedir '/path/to/my/homedirectory/.gnupg'". Checking the permissions on /.gnupg gives

drwx------ 3 username username 4096 Apr 21 16:00 .

for the directory and this for the files inside:

-rw------- 1 username username   43 Apr 21 16:00 gpg-agent.conf
-rw------- 1 username username  258 Apr 21 16:00 gpg.conf
drwx------ 2 username username 4096 Apr 21 13:25 private-keys-v1.d
-rw------- 1 username username   32 Apr 21 14:02 pubring.kbx
-rw------- 1 username username 1200 Apr 21 14:02 trustdb.gpg

The directory /private-keys-v1 is empty.

I would greatly appreciate any help since I have lost access to all my private files.

  • Had you ever restored from a backup before you did the install? In other words, did it used to work? – Organic Marble Apr 21 '18 at 12:46
  • No, since there was no need for a restore while everything worked fine. – needhelp Apr 21 '18 at 12:50
  • You can get some information on the problem by doing the command sudo duplicity collection-status file://[location of your backup directory] I suggest you do that and edit the results into your question. It may just repeat the CollectionsError you already got though. – Organic Marble Apr 21 '18 at 12:53
  • The command returns that it has "found 1 secondary backup chain" and "Found primary backup chain with matching signature chain:". – needhelp Apr 21 '18 at 12:59
  • Have you imported the gpg keys after reinstall? – vidarlo Apr 21 '18 at 13:03
1

What seems to be working for me (the recovery is currently halfway through) was the command

duplicity --gio file:///media/backup /tmp/restore

where I've replaced media/backup and /tmp/restore with the filepath to the backups and my recovery destination, respectively. After entering the GNUpg passphrase I've chosen when setting up the backups in Deja-dup, the recovery process started.

For more detailed information please refer to this guide.

  • That's a useful guide, thanks for the link. Glad it's working. – Organic Marble Apr 21 '18 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.