1

This question already has an answer here:

Update:

It seems infinite login is a Ubuntu 16.04 problem. There is no infinite login on Xubuntu 16.04, but I will encounter Nvidia card problem described below.

I also tried Ubuntu 17.10. Ubuntu 17.10 actually can detect my Nvidia card. However after installing the driver, whenever I boot my machine, it will get stuck on loading, with black screen flickering.

I described in my answer that I switched to use Xubuntu 16.04. I managed to install Nvidia driver through PPA, and I did not get stuck on the log in screen. I have set secure boot to off. I now switch to use a proprietary driver. This way I can open Nvidia settings, but Nvidia settings does not list any GPUs.

However, something is still wrong with my graphics card.

  1. I did

     $ sudo lshw -C display
     *-display               
       description: 3D controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:ec000000-ecffffff memory:c0000000-cfffffff memory:d0000000-d1ffffffioport:e000(size=128) memory:ed000000-ed07ffff
     *-display UNCLAIMED
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:eb000000-ebffffff memory:80000000-8fffffff ioport:f000(size=64) memory:c0000-dffff
    
    $ lspci
    00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
    
  2. In Software & Updates the graphic card is unknown:

  3. With PPA installed open source Nvidia drivers, when run nvidia-settings:

    Xlib:  extension "GLX" missing on display ":0.0".
    ERROR: Unable to load info from any available system
    
  4. At this point, I cannot:

    • change brightness either through function keys or through apps,
    • detect or extend to second monitor
  5. Per requested:

    $ uname -a     
    Linux wei-XPS-15-9560 4.13.0-38-generic #43~16.04.1-Ubuntu SMP Wed Mar 14 17:48:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
    
    $ dpkg -l nvidia\* | grep '^i'
    ii  nvidia-384                       384.111-0ubuntu0.16.04.1 amd64        NVIDIA binary driver - version 384.111
    ii  nvidia-opencl-icd-384            384.111-0ubuntu0.16.04.1 amd64        NVIDIA OpenCL ICD
    ii  nvidia-prime                     0.8.2                    amd64        Tools to enable NVIDIA's Prime
    ii  nvidia-settings                  361.42-0ubuntu1          amd64        Tool for configuring the NVIDIA graphics driver
    
    $ dkms status
    bbswitch, 0.8, 4.13.0-38-generic, x86_64: installed 
    nvidia-384, 384.111, 4.13.0-38-generic, x86_64: installed
    nvidia-384, 384.111, 4.4.0-119-generic, x86_64: installed
    

    Xorg.0.log

Original problem:

I know that this may have been asked numerous times, but none of the solutions I found online worked.

I am running a new XPS 15 9560 with GTX 1080. I installed the Ubuntu 16.04 today, following this instruction .

In particular, I followed the above instruction to use PPA to install a Nvidia graphics driver. I also disabled secure boot on my machine. I got into an infinite login loop no matter which driver I use. I can manage to get out of the login loop by uninstalling the driver. I could not get the Nvidia driver to work no matter how.

I have looked at .xsession-erros:

line 1: Xlib:: command not found
line 2: Xlib:: command not found
line 3: openConnection:: command not found
line 4: cannot: command not found
line 5: syntax error near unexpected token '('
line 5: 'upstart: gnome-session (Unity) main process (1497) terminated with status 1

I have also tried the method mentioned in this post: Ubuntu gets stuck in a login loop. I did have

-rw-------  1 root root   53 Nov 29 10:19 .Xauthority
drwxrwxrwt 15 root root 4096 Nov 30 04:17 /tmp.

However changing ownership (chown) of .Xauthority and .ICEauthority did not help. I cannot login to either of my account or the guest account.

marked as duplicate by George Udosen, David Foerster, Eric Carvalho, Elder Geek, anonymous2 Apr 24 '18 at 12:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @GeorgeUdosen Thank you for replying. I tried the solution in that post and still couldn't get Nvidia to work. – W.W Apr 21 '18 at 6:42
  • @DavidFoerster Thank you for replying. I have updated my question. Let me know what other information would be useful. – W.W Apr 22 '18 at 1:45
  • @DavidFoerster. I forgot to put it. Now there is a link for my Xorg.0.log – W.W Apr 22 '18 at 20:24
  • The proprietary Nvidia graphics adapter driver was loaded successfully according to the X.org log but there was no compatible graphics adapter. This is in line with the lspci output but contradicts the lshw output. Which Nvidia GPU is supposedly built into the computer in question? Can you please verify that lspci -nn | grep -Fe '[0300]' lists no Nvidia VGA adapter indeed? Could it be disabled in BIOS or by some hybrid graphics solution like PRIME or Bumblebee? What happens if you disable the integrated Intel graphics adapter in BIOS? – David Foerster Apr 22 '18 at 20:47
  • @DavidFoerster It is supposed to be a GTX 1080. 'lspci -nn | grep -Fe '[0300]' ' only lists the Intel VGA controller – W.W Apr 22 '18 at 20:50
0

I kind of solved the orignal problem by.... using Xubuntu 16.04 LTS.

I do not understand why things didn't work on Ubuntu, but I have seen several others who experienced similar problems with Nvidia driver on Ubuntu 16.04 on a Dell XPS 15 9560, and they solve it by switching to a Xubuntu or Linux Mint,such as this one.

I will try to make CUDA work later.

Not the answer you're looking for? Browse other questions tagged or ask your own question.