3

Sorry if I'm missing something obvious; I'm new to Ubuntu/Linux in general. I'm trying to set up a Japanese IME like Windows', and I'd heard that ibus was the program to use. I have it installed, I've run ibus-setup to turn on the daemon and set the language to Japanese, but it's still typing in English. I've looked in System Settings to change the input method, but I can't seem to find it anywhere. Any suggestions?

  • ibus-mozc or ibus-anthy, also fcitx-mozc or fcitx-anthy, some of these would solve and fit to the system. – psw1747 Apr 21 '18 at 10:37
0

How to make it work

A bashed my head against this for a while as well. Here is what worked for me and how I got it together. Some of the steps might not be needed for you. All of this was tested on Kubuntu 16.04:

  1. Install an input method that supports kana input. I installed the following:

    sudo apt isntall ibus ibus-mozc fcitx-mocz fcitx-frontend-all
    
  2. I had to convince KDE to use fcitx as the input method:

    sudo apt install qt4-qtconfig
    qtconfig
    

    Then I selected fcitx as the default input method at: Interface -> Default Input Method

  3. Start fcitx as a demon. This will complain, if it is already running.

    fcitx -d
    

    After this a small keyboard icon should appear in your system tray.

  4. Right-click the icon and select Configure input method. There you will get the option to add input methods by clicking the +-icon. Add your default desired keyboard (for me this was German) and Mozc (I needed to log out and in again for this to show up).

  5. Now you can toggle between input methods with Crtl + Space .

Right now, I have not tried to make fcitx start automatically, but one of the sources showed how that works. I will update the answer, if I get it to work.

Edit: Start automatically

I had to create a .xsessionrc file in my home folder and add the following lines:

export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=@im=fcitx

fcitx -d

which automates the steps 3 and 4. This works for me using sddm, other systems might require a different setup. Another option to put this is the .xprofile file, if the above is not working for you. (This worked for a friend of mine who runs Gentoo with KDE.)

Second Edit: Black box instead of tray icon

The method above (.xsession) only worked for one startup, after that, I did not see the keyboard indicator in the system tray, only a black box. I was able to fix that by removing the line that starts fcitx from the script and start it via System Settings -> Startup and Shutdown -> Autostart -> Add Program where I added fcitx -d.

Sources

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.