1

Background

Two weeks ago, I was on the kernel 4.13.0-36, and a routine update installed 4.13.0-37 and 4.13.0-38 automatically. After that, I was unsuccessful in getting my laptop to boot beyond the login screen (this is a documented bug affecting several users). I fixed (temporarily solved) it by removing -37, -38, and apt-mark holding -36. I continued to boot in -36 without any issues for about two weeks now.

Problem

I used my laptop as usual last night and then eventually shut it down. I believe I ran some routine updates through apt. Today morning I was unable to boot past the login screen.

Situation: My grub pops up by default. Then I choose the top option, which is -36. It runs through the boot process, asking me to unlock cryptswap. I do that. It finishes up, shows the login screen. Irrespective of whether or not I interact with it (e.g., moving the cursor around, typing my password really quick, or even booting into tty2 or any other tty), it freezes in the next 6 seconds or so.

My current suspicion is that the problem must be caused by some recent package that was updated, or something to do with the kernels. Whatever it is, is crashing at login while trying to launch GUI. If I understand correctly, it is likely to be some process that occurs at startup.

Things I have tried without much luck

  • nomodeset option: no luck with -37, -38, but -36 boots. Can't suspend.
  • -36 recovery boot, and then trying to dpkg repair packages
  • chroot followed by apt upgrade (according to this answer)
  • reinstalling -37, -38 because apparently "a fix was committed" at the same link to the bug above. (tried nomodeset with all these kernels, too, didn't work)
  • switching to another tty: doesn't work because machine freezes irrespective of what you do within 5-6 seconds

Logs and info

I'm just trying to provide down here anything I think is relevant. If you believe something else might help, please let me know and I'll be happy to upload it.

  • DMESG output through chroot session (link redacted)
  • Auth log for one such failed boot (link redacted)
  • dpkg log from the last successful graphical session (yesterday) (1. all: link redacted; 2. only recently installed, filtered using grep "install": link redacted)
  • syslog from one such failed boot (link redacted)
  • Basic information about hardware using lspci (link redacted)
2

I have experienced the same on 17.10. Although you are on 16.04, the freeze seems to be common to both versions and may be this issue or that issue.

sudo apt purge intel-microcode

suggested did not work for me but installing latest mainline kernel 4.16.3-041603-generic did solve the freeze. I used ukuu to easily install this kernel, great utility!

  • I'm currently trying this out: bugs.launchpad.net/ubuntu/+source/intel-microcode/+bug/1759920, and later planning to try your solution. – Aalok Apr 22 '18 at 23:18
  • rm'ing intel-microcode seems to do the trick. However, I haven't gone as far ahead to install the 4.16.x kernel(s). I read that 4.13.39-x was released which seems to be fixing this bug, but I'm probably going to avoid an update at this point and remain on this stable state – Aalok Apr 23 '18 at 16:05
  • Also, I didn't just rm it, but I also reinstalled the older version of intel-microcode (See the "workaround" part of the following entry: bugs.launchpad.net/ubuntu/+source/intel-microcode/+bug/1759920) – Aalok Apr 23 '18 at 16:07
  • sudo apt purge intel-microcode seems to work for me too – silgon Jul 30 '18 at 21:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.