0

I've been playing around with Docky for about 2 hours and have failed consistently at removing the anchor icon from it. I have read numerous pages all telling me the same solution which is to disable it from gconf-editor. I have tried this as well as reinstalling the app several times from both the terminal and the software application. I've tried deleting every configuration file I could find (~/.gconf, ~/.local and ~/.cache) and reinstalling from both terminal and the software application.

While writing this, I ran sudo gconf-editor and the box wasn't ticked. However gconf-editor still had the box ticked.

Message in terminal when I try edit the setting from gconf-editor:

GConf Error: Configuration server couldn't be contacted: D-BUS error: Unable to store a value at key '/apps/gconf-editor/recents', as the configuration server has no writable databases. There are some common causes of this problem: 1) your configuration path file /etc/gconf/2/path doesn't contain any databases or wasn't found 2) somehow we mistakenly created two gconfd processes 3) your operating system is misconfigured so NFS file locking doesn't work in your home directory or 4) your NFS client machine crashed and didn't properly notify the server on reboot that file locks should be dropped. If you have two gconfd processes (or had two at the time the second was launched), logging out, killing all copies of gconfd, and logging back in may help. If you have stale locks, remove ~/.gconf*/*lock. Perhaps the problem is that you attempted to use GConf from two machines at once, and ORBit still has its default configuration that prevents remote CORBA connections - put "ORBIIOPIPv4=1" in /etc/orbitrc. As always, check the user.* syslog for details on problems gconfd encountered. There can only be one gconfd per home directory, and it must own a lockfile in ~/.gconfd and also lockfiles in individual storage locations such as ~/.gconf Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

Note that editing it in gconf-editor says read only and I am unable to change anything. The message above appears when I click on a setting even though it doesn't change.

OS Info:

OS: Ubuntu 16.04 xenial

Kernel: x86_64 Linux 4.13.0-38-generic

Shell: bash 4.3.48

DE: XFCE

WM: Xfwm4

  • Did you try: gconftool-2 --type Boolean --set /apps/docky-2/Docky/Items/DockyItem/ShowDockyItem False from a terminal window. – Terrance Apr 20 '18 at 16:45
  • It didn't work, unfortunately. – Jakey Snakey Apr 20 '18 at 17:25
  • What version of Xubuntu are you running? I tested that line on my system and it is Xubuntu 16.04. – Terrance Apr 20 '18 at 17:26
  • I edited that info into the post. – Jakey Snakey Apr 20 '18 at 18:39
  • Can you run the following command and give the output on it? ls -al /usr/lib/dbus-1.0/dbus-daemon-launch-helper – Terrance Apr 20 '18 at 19:15
0

I ended up doing a complete reinstall of Xubuntu and the problem was fixed. I am assuming that I messed with some files that I shouldn't have, but not sure.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.