0

I am running ubuntu 16

System A: eth0 is connected to internet via proxy, eth1 is connected directly to a second computer System B: has one NIC and it is connected to eth1 on system A

System A eth1 is set for Shared via the network manager GUI. System B has Gateway and DNS set to System A eth1's address. I have also tried just setting the address to match System A eth0's gateway and DNS

On System B, I can ping the DNS server so the shared connection is at least partially working. However, when I try to connect anywhere, the DNS does not resolve not even the proxy URL. However I can ping the IP addresses.

By default, /etc/resolv.conf is set to 127.0.1.1 I've tried setting it to 127.0.0.1, System A eth1 address, and System A eth0's DNS address

  • Hi, Welcome to ask ubuntu. Please read these q/a: askubuntu.com/questions/754213/…, askubuntu.com/questions/2321/…. They should at least help you get over a couple misunderstandings you have on networking. (127.0.0.1 always refers to the loopback interface -- myself, not another system). Re-asking your question after looking at those will draw better answers I suspect. – dpb Apr 21 '18 at 3:46
  • Yes, I am aware 127.0.0.1 refers to the loop back device. I was not familiar with 127.0.1.1 until I saw the link you sent me. This is what it was originally set to but it still did not work. Setting /etc/resolv.conf to the actual dns server should work and I know I can connect to it because I can ping it. My issue is more with getting DNS to work on a shared connection. I used the GUI to set it up but it still does not work. I've never encountered an instance where I could ping the DNS, yet it didnt work even after setting it. – eng3 Apr 22 '18 at 4:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.