2

I'm trying to send my system to sleep using e.g.

rtcwake -v -m disk -s 60

and receive the following output

rtcwake: RTC wird als UTC interpretiert
UTC wird verwendet.
    delta   = 1
    tzone   = 0
    tzname  = UTC
    systime = 1524206927, (UTC) Fri Apr 20 06:48:47 2018
    rtctime = 1524206926, (UTC) Fri Apr 20 06:48:46 2018
Alarm 0, sys_time 1524206927, rtc_time 1524206926, Sekunden 60
rtcwake: wakeup from "disk" using /dev/rtc0 at Fri Apr 20 06:49:47 2018
suspend mode: disk; suspending system
rtcwake: write error

The system seems to start entering the suspend mode but returns back immediately. I'm running Ubuntu 16.04.4 LTS (GNU/Linux 4.13.0-38-generic x86_64). Are there any details, that would help to find the root cause of the problem (dmesg output, /var/log/syslog, ...)?

Thanks in advance,

Bernd

  • 1
    Have you tried mem instead of disk with -m switch? I am guessing hibernation is not possible on the machine since there is not enough swap mem, have you checked this? I am guessing that is the reason why it returns immediately. – Abel Tom Apr 20 '18 at 9:33
  • 1
    Actually in the meantime I have found the problem. After adding 'hpet=disable' to the Kernel paramters, everthing works as expected. – Bernd Apr 20 '18 at 10:24
  • The hpet trick does not work for me... :-/ – xtof54 Aug 14 '18 at 6:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.