26

I'm using Ubuntu 11.10 with Unity.

Switching between applications (Alt + Tab) works, but switching between windows of one application (Alt + ') doesn't. Tried to assign Alt + ' switching to another shortcut (Super + ', Ctrl + ', Alt + F1, using system settings) but nothing works.

After install, everything was working fine.

I have ' (apostrophe) instead of `. To get that, I edited files in the /etc/X11/xkb/symbols. Of course, if this matters.

Seems like there is a problem with assigning shortcuts using system settings. When I assign between windows of the same application to Alt + Tab, it still switches between different applications. No idea what's going on.

UPDATE: The problem is fixed. I've been changing different settings of my keyboard, and one of the settings changed was XKBMODEL. I set it to "latitude" (thought it would fit better, that was really stupid). After I changed it back to "pc104", everything worked normally again. Thanks everybody for your attention!

UPDATE 2: The ` symbol still needs to be in it's place for US layout. For Russian I was able to leave ' assigned to "TLDE" button.

UPDATE 3: Seems like I have got the same problem with "Switch between windows of the same application immediately" (which is Alt + Esc by default). It doesn't work, and assigning it to another shortcut doesn't help. Any suggestions?

  • Have you tried editing the /etc/X11/xkb/symbols/ back to ` instead of ' ?? – rlemon Feb 8 '12 at 22:45
  • also according to here /etc/X11/xkb/symbols/ was moved to /usr/share/X11/xkb/symbols/* – rlemon Feb 8 '12 at 22:47
  • @rlemon I've changed it back to "key <TLDE> { [ grave, asciitilde ] };". Unfortunately, I didn't make any backups before modifying this file, so I'm not sure if this is what I need. – Andrii Chernenko Feb 8 '12 at 23:04
  • What keyboard layout do you use? The window switching is usually mapped to the button above the Tab key: for example, in the case of the Hungarian keyboard layout it is mapped to <kbd>Alt</kbd>+<kbd>0</kbd>. So it depends on your keyboard layout, what key combination do you have to press to switch between windows. You could try to switch to an another keyboard layout, and see what happens. – toros Feb 8 '12 at 23:12
  • I use English and Russian layouts, and both have "key <TLDE> { [ grave, asciitilde ] };". <TLDE> is the key above tab. Besides that, why do my attemps to assign windows switching to another shortcut fail? – Andrii Chernenko Feb 8 '12 at 23:23
24

This was my problem too. Alt+<key above tab> didn't work to switch windows in the current application.

In addition, when i pressed and held down the super key to see the unity shortcuts, normally one would see this:

enter image description here

I'm assuming that is for a US keyboard? I stole the screenshot from another post, and on my danish keyboard it now shows Alt + Onehalf.

But when I had this problem, I did not see the line pointed to by the red arrow!!!

So check if you see a keyboard shortcut for "Switch windows of current application". If you don't this is for you:

The fix was as hinted at above to change the XKBMODEL setting in /etc/default/keyboard where I changed from XKBMODEL="microsoft4000" to XKBMODEL="pc105".

I did that and ran sudo dpkg-reconfigure keyboard-configuration. Not sure this last step was required.

Then I needed to reboot.

Now it works.

8

Suboptimal, but you can use the down arrow after Alt + Tab.

  • 1
    Yes, that's an option, but <kbd>Alt</kbd>+<kbd>`</kbd> would be a lot better. – Andrii Chernenko Feb 8 '12 at 23:28
  • No disagreement here. – Amanda Feb 8 '12 at 23:29
  • 1
    @Amanda Thanks, I was unaware of this trick which works for me much better than the required feature, so your answer is to me superoptimal... – Filippo Alberto Edoardo Jan 5 '17 at 18:18
8

You can change the short cut key of "switching windows" to Alt +Tab. Then you will be able switch between windows (not applications)

Exclusive for ubuntu 18.04 LTS - search keeyboard in settings and do the above change

4

In Ubuntu 18.04, at least with Vanilla Gnome3, press Alt+Esc for switching windows direct

3

In Ubuntu 18.04.1 the default shortcut to switch between windows of same app is

Alt + F6

See Screenshot Here

  • Use shift to go backward in order. – gMale Mar 28 at 15:28
0

What about then you Tab to your target window and Enter?

  • You have a enough reputation to post a comment. So do not post comment in answer section. – d a i s y Jan 18 '17 at 4:01
  • @daisy, actually it is an answer... But I've made it as a question.. what is the problem? Karel, thanks for your edition. – Bruno João Jan 18 '17 at 10:41
  • The behavior is the same as alt+tab in my ubuntu. Which is not the "common" behavior for alt+tab. – Fábio Dias Jun 13 '18 at 16:00
0

Just press Super for 3 seconds and you will see the screen “Unity Shortcuts for Your Keyboard”:

Unity Shortcuts for Your Keyboard

There you will find your shortcut according to your keyboard and yes it's Alt+The key above Tab.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.