I'm running a laptop with Nvidia Optimus on Xubuntu 18.04, and I can't seem to get the nvidia drivers to work at all.

I've run both Kubuntu 18.04 and Ubuntu Budgie 18.04, and was able to login using nvidia-390 drivers (although the login screen was black until I tried logging in, which allowed me to log in using nvidia drivers, the login screens just never loaded?), but on Xubuntu 18.04, it feels like I've tried everything to get nvidia drivers to work period. I've tried upwards of 6 different nvidia drivers (340, 380, 384, 390, there's likely some others I'm forgetting), tried running nvidia-xconfig, tried deleting /etc/X11/xorg.conf, even trying editing grub boot options.

The closest I have seemingly gotten is changing no grub boot options, installing any nvidia driver, and running nvidia-xconfig. This still doesn't allow me to boot into the login screen, but it will show the splash login screen as always, but the bootup will freeze with a non-blinking cursor in the upper left of the screen.

I can get into a TTY with CTRL+ALT+F1, and make changes there, I just am never able to actually get into a login screen. Grub is completely viewable, and without doing nvidia-xconfig, I can still get into a TTY, but the screen is completely blank until I enter a TTY, as opposed to with nvidia-xconfig, where I can get into a TTY, but it freezes on that non-blinking cursor.

I've been banging my head against a wall for days trying to figure this out, so any help is appreciated, and I can get more information as needed.

  • Just checking, do the nouveau open source drivers work on this system? Since this is an optimus system, have you done anything with bbswitch/bumblebee and the like?
    – sbergeron
    Commented Apr 19, 2018 at 15:35
  • have you checked that the login screen is installed? could be a broken installation, or no installation at all. and what dm are you using? as mentioned above, try to add the nouveau driver in grub, and see if that boots up, may just be a misconfiguration Commented Apr 19, 2018 at 16:04
  • I can try to use the nouveau driver, and I've reinstalled the OS ~3 times while testing this, so I don't think that the installation has been broken all three times. Pretty sure that I'm using lightdm? I believe that is the default in Xubuntu.
    – Ness
    Commented Apr 19, 2018 at 18:52
  • 1
    There have been big changes to the nvidia drivers in 18.04. And they are not good. I have two Optimus laptops, and I can't think of any good news to report. The root causes seems to be bug in systemd which means the nvidia card can not be turned off by bbswitch, and this has cascading consequences. I will stay on 17.10 and pray for a miracle. I can get it to log in with lightdm but it breaks easily and it is slow to switch intel/nvidia modes since it completely uninstalls/install nvidia and rebuilds initramfs. The devs have struggled to get something which works at all, I think. Commented Apr 20, 2018 at 6:48
  • 1
    I gave up with ubuntu 18.04. I think the new approach is irredeemable. Even if the logind bug is fixed, the new prime-select is committed to a restart. I'm sure there is a reason for this backwards step, but right now I have the latest Nvidia driver on Mint 18.3 and changing between nvidia and intel with no reboot required (so Mint is not affected by any of the preime-select problems of Ubuntu 18.04) Commented Apr 29, 2018 at 13:36

4 Answers 4


I used Xubuntu 16.04 and it worked good, just one time issues with NVIDIA drivers, but since then i didn't have issues. Well with coming of Xubuntu 18.04 i had no cuda support in Blender. I though it was a problem with Quadro GPUs... then i removed Quadro, got a new Gigabyte GTX 750 ti 4GB Ram, did a fresh reinstall and configured the drivers, but on rendering in Blender was running in Xeon CPU. Tried to install drivers from NVIDIA and setup failed in TTY1. I formatted again the machine, downloaded again NVIDIA drivers and still it failed. During these installations and tests, it i had several bugs.

Probably i will install old Xubuntu 16.04 again. I think there is something wrong on new LTS versions of Ubuntu family and between loosing all this time trying to make it work... instead of install and get back to the work there is a huge difference. Of course this is not the kind of way i like to spend my time or getting other GPU cards hopping this or that might work.

I hope someone fix this soon.


I'm having this issue as well. Best solution I have found is:

sudo apt remove libnvidia-ifr1-390 libnvidia-ifr1-390:i386 nvidia-driver-390

This just allows non nvidia updates to continue but does not solve the issue itself.


Here is a live iso xubuntu-bionic with nvidia-390.48 and prime from MatheuGras-TimRichardson

It switched correctly on live testing with Acer VN7 laptop 4GB


Screenshots + Logs are on the site

  • People should not install modified versions of xubuntu (or any other distribution) from unknown sources!
    – Ravexina
    Commented Aug 4, 2020 at 11:22

I had the same problem with my Xubuntu 18.04 version that runs on Nvidia GPU.

I tried installing the latest Nvidia-390 and nvidia-prime drivers and updated my driver installs as shown in Is nomodeset still required? and Trying to install Ubuntu results in freezing splash screen - nomodeset did not work, and I added nouveau to the block list, but none of these worked.

So what I did is that I added the parameternouveau.modeset=0 to grub.cfg file in \boot\grub\ directory. I added the line after every "linux..." line, for instance:

menuentry 'FAILSAFE' --class ubuntu --class gnu-linux --class gnu --class os {
    set gfxpayload=$linux_gfx_mode
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos8)'
    search --no-floppy --fs-uuid --set=root 36286167-4eba-4a1e-a202-155c6baafa01
    linux /boot/vmlinuz-2.6.37-12-generic root=UUID=36286167-4eba-4a1e-a202-155c6baafa01 ro vt.handoff=7 quiet splash nouveau.modeset=0
    initrd /boot/initrd.img-2.6.37-12-generic

So, I believe you have to add this parameter in all the script. I tried this solution and Nvidia GPU driver stopped crashing.

Another approach as described in Ubuntu 18.04 stopped working with NVIDIA drivers

Execute sudo nano /etc/default/grub and add the parameter nvidia-drm.modeset=1 between the double quotes to the line beginning GRUB_CMDLINE_LINUX_DEFAULT. Save the change you've made and run sudo update-grub.

Restart the Ubuntu operating system, and now, everything should work properly - right as expected.

  • it is not a good idea to edit /boot/grub.cfg as it gets regenerated automatically when update-grub is called, which happens automatically when, for example, a new kernel is installed, and also you may make a syntax error that causes the system to become unbootable. Instead you should add that parameter to /etc/default/grub as you described in relation to the second option.
    – Zanna
    Commented Aug 4, 2020 at 11:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .