198

I'm wondering why I have (base) on the left of my terminal prompt.

Image of my prompt

If I run source ~/.profile in the terminal, it disappears.

If I close that terminal and reopen a new terminal, (base) is there again.

I'd like to know what it is.

Here's the content of my .profile (excluding standard $path stuff and other personalized things):

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
        . "$HOME/.bashrc"
    fi
fi

Here's the content of my .bashrc

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color|*-256color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# colored GCC warnings and errors
#export GCC_COLORS='error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01'

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi

# added by Anaconda3 installer
#export PATH="/home/jim/anaconda3/bin:$PATH"
. /home/jim/anaconda3/etc/profile.d/conda.sh
conda activate
0
106

This appears to come from your conda environment. In particular, you are activating conda from your ~/.bashrc as follows

# added by Anaconda3 installer
#export PATH="/home/jim/anaconda3/bin:$PATH"
. /home/jim/anaconda3/etc/profile.d/conda.sh
conda activate

and conda activate prepends your prompt with (<env-name->) - because you are not specifying a particular environment, that defaults to (base).

The behavior is documented at Using the .condarc conda configuration file:

Change command prompt (changeps1)

When using activate, change the command prompt from $PS1 to include the activated environment. The default is True.

EXAMPLE:

changeps1: False

So to make it go away, either find and modify your .condarc file - or don't activate conda from your ~/.bashrc file.

2
  • 11
    Keep in mind that you can also do conda config --set changeps1 False instead of searching for the file. To make the changes apply immediately execute exec bash in order to reload the .bashrc. – Markus Jan 16 '20 at 22:18
  • 3
    Another solution is to override PS1 environment variable after executing conda initialization script in .bashrc. I already had a custom PS1 so this caused it to not show (base) when starting a shell but rather it's appending it whenever I activate a virtual environment. Just like I wanted. – 8bra1nz May 4 '20 at 5:48
232

This can also be because auto_activate_base is set to True. You can check this using the following command

conda config --show | grep auto_activate_base

To set it false

conda config --set auto_activate_base False
source ~/.bashrc

To reactivate set it to True

conda config --set auto_activate_base True
source ~/.bashrc
8
  • 8
    This command finally helped me! The other solutions didn't work because my changeps1 was already set to false. The error in my case came to be after I installed matplotlib via conda. Before (base) would never show. Thanks for adding the line to check the config! – Andrusch Feb 13 '19 at 10:24
  • 1
    finally someone hits the mark. But do you know why that value is suddenly switched to True? (In my case it was not like that for a long while) – HongboZhu Feb 14 '19 at 10:16
  • 2
    PS: the terminal must be closed and re-opened for the change to take effect – Nino Filiu Apr 25 '19 at 12:09
  • 3
    This appears to have worked for me as well. However, my goal was only to remove the (base) characters from the command prompt; I do not want to change my conda/python/jupyter/etc setup. > Will this only remove (base) from the prompt without any side-effects? If not, what could the side-effects be? – TransferOrbit Apr 25 '19 at 18:37
  • Thanks for the solution. It worked for me. – Suraj Dubey Aug 4 '19 at 6:32
42

(base) appears due to change in conda environment.

The following command hides (base) environment.

conda config --set changeps1 False
2
18

To deactivate a conda environment, enter:

conda deactivate

This will remove the (base) before your Linux prompt, as seen here:

(base) user@office-pc:~$

0

from your $HOME directory echo "changeps1: False" >> .condarc

-1

ran the code below then entered conda deactivate and the base went away.

echo >&2 "DeprecationWarning: 'source deactivate' is deprecated. Use 'conda deactivate'."
"$_CONDA_ROOT/etc/profile.d/conda.sh" || return $?

conda deactivate

-1

It appears to still be an experimental feature of Anaconda.

To revert it back to normal you can run the command:

conda init --reverse

Then you need to close the current shell window and open a new one to see the modifications.

Not the answer you're looking for? Browse other questions tagged or ask your own question.