0

OK, so I have dabbled with Linux for a while but nothing too serious (so bear with me). Have set up Ubuntu as a main desktop and wanted to add a networked printer. Have set this up while ago using Lubuntu and all worked fine. However, this time I am struggling and have read a large number of threads but nothing helps. I cannot print and am getting various errors mainly saying that the printer is not found etc. I have used nmap and am getting "all 1000 scanned ports on (printer IP) are closed". This is rather odd, it's an out of the box install. Have tried disabling iptables, same result. On the machine where I have lubuntu installed I get Port State Service 91000/tcp open jetdirect

I can ping the IP address of the printer

Any idea what might be wrong? Is there something wrong with my network profile? firewall? Something different?

1
  • 1
    That doesn't sound right. What commands did you use? E.g. if my network was 192.168.1.x, I would do nmap -sP 192.168.1.0/24 to verify the devices. This also checks that you have a working network. If my printer was 192.168.1.10, I would then do: nmap -sS -F 192.168.1.10 to look for the JetDirect port. How does that compare with what you did? – Martin W Apr 17 '18 at 20:05
0

OK, sorry, just answered my own question. I did some more digging and the realised that my stupid sky router has given out the IP of my printer (fixed) to my machine. Totally odd, even though I have reserved the IP of that printer. Gave my machine a temporary fixed IP which is different from the printer and it's now working as on my other machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.