1

I am trying to install Ubuntu 16.04 on a new Dell XPS 15, 16gb Ram, i7 7700 CPU, 512gb SSD.

Windows is already preinstalled which I want to keep for the odd admin task so I added a partition of 220gb for my main Ubuntu machine. I have tried installing using the same boot drive I used on my new PC about 2 weeks ago which worked fine on there but I am just getting numerous errors when trying to install on this new machine.

terminal output 1 terminal output 2

I also tried installing the latest elementary OS with similar issues.

As the console was mentioning CPU I downloaded and ran the intel processor test and everything came out fine. Windows is also running well, or as well as it does so hardware seems fine.

Any ideas on how to resolve this?

I have tried three different usb drives all with the same result and also multiple ports on the machine itself.

1

I'm an owner of the XPS 9560, I think the same system. There's an XPS specific bug at the moment that requires adding

acpi_rev_override=1

to the boot params to avoid a soft lockup when accessing the dedicated GPU in any capacity. In grub when booting the installer, tap "e" then add acpi_rev_override=1 after quiet splash and it should boot properly.

  • 1
    Thank you so much for that! It worked a treat, and yes I am running an XPS 9560 too :) It would have taken me multiple life times to work that one out. – user8467470 Apr 17 '18 at 19:17
  • Took me a ridiculous amount of time as well when I had to find it, it probably didn't help that I was installing arch just a month or two after it came out--no one knew why things wouldn't work, it had to do with weird changes that came to optimus with the 10xx series GPUs. The installer would boot, then crash as soon as you tried to enumerate pcie devices. – sbergeron Apr 17 '18 at 19:22
  • Haha. Rather you than me. I am a web dev so have enough bugs in my life already :) Do I need to reconfigure the drivers or anything once installed? I am trying elementary but won't shut down or restart so something going on there. – user8467470 Apr 17 '18 at 19:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.