0

I have IntelliJ Idea Ultimate installed on both Windows 8.1 & Ubuntu 16.04 on the same laptop, but different partitions. If I'm using Windows and set up the maven directory to the installed one on Windows's local disk C, it works, but after I'll restart the computer on Ubuntu, when entering IntelliJ I get a notification saying Maven directory is invalid, because it somehow remains the one from Windows, despide I also have Maven installed on Ubuntu on a separate Ubuntu partition. Of course I can set the path for the Maven's location on Ubuntu, but I don't want to do this all the time I'm switching operating systems.

I'm not sure, does these two IntelliJ's (the one from Windows & the other one from Ubuntu) communicates somehow? I'm not having problems using Tomcat, for instance, which I also have on both Windows & Ubuntu.

Invalid Maven home directory configured
C:/apache-maven-3.5.2 
Bundled maven 3.3.9 will be used.  Configure Maven home.

IntelliJ

  • Are you working on the same project in both? If not, do you have some common partition between windows and ubuntu where you store certain config files? – sbergeron Apr 17 '18 at 16:45
  • Yes, I have the same project opened in both Ubuntu 16.04 and Windows 8.1 and the project is located inside the same partition, but IntelliJ is installed on different partitions on Windows and Linux. Somebody suggested some 'sync settings' may or may not be enabled/disabled, but I don't really know where to find them by this name ('sync settings'). – BR4TO92 Apr 17 '18 at 18:16
  • What you may be able to do is put the maven installation directory on that shared partition. See if when you do so intellij is able to handle translating paths correctly. Another solution could be to add some variable to your path on both windows and ubuntu and have intellij reference that. – sbergeron Apr 17 '18 at 18:23
  • It won't recognise the correct path if I'll put maven in the shared partition since it doesn't translate the path to linux's format with the current one. – BR4TO92 Apr 22 '18 at 12:13
1

On your Linux OS, check the file permissions of the maven.jar file in the ../plugins/maven/lib folder. Pretty sure it should have execution rights for at least your user if not the group as well.

Seems like some of those maven jar files have not always been marked executable in the past when they should have been.

I think I found this beginning with IntelliJ 2016 and on.

You might try comparing the permissions of your personal install of maven with those "bundled" with IntelliJ to ensure they have the same permissions.

Also, make sure that the "program" files, and scripts, are executable. These are found in ../plugins/maven/lib/maven3/bin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.