0

I recently asked a question here about bugzilla, but I think it's really just my apache2 install. when browsing to http://my.ip.addr I get this text:

Index of /

[ICO] Name    Last modified   Size    Description
Apache/2.4.18 (Ubuntu) Server at 192.168.0.13 Port 80

instead of the welcome screen. Most of the docs I found simply said to install apache2 and I should be up and running.

In the other question, I had two errors, one about the missing prefork package, and one about the ps output. Given that apache is so widely used, it's weird to me that it wasn't more straight-forward.

I found this doc that is more specific to 16.04, and it says to run the ufw command.

Update

ufw status:

Status: active

To                         Action      From
--                         ------      ----
Apache Full                ALLOW       Anywhere                  
22                         ALLOW       Anywhere                  
Apache Full (v6)           ALLOW       Anywhere (v6)             
22 (v6)                    ALLOW       Anywhere (v6)             

I have this in my apache2.conf. (I changed it a couple of times, what should the correct value be?)

<Directory /var/www/html/>
        Options Indexes FollowSymLinks
        AllowOverride None
        Require all granted
</Directory>

And I do have the /var/www/html/index.html file present. With the directory value set as above, I get this message when viewing in a browser:

Forbidden

You don't have permission to access / on this server.

update I resolved this by purging/removing apache2 and re-installing.

0

First of all, if you want to enable firewall, do:

sudo ufw enable

You can check status of firewall by:

sudo ufw status

Then check whether apache2 is running:

sudo systemctl status apache2

If it shows active then it is running, otherwise do:

sudo systemctl start apache2

If there is Permission error then do:

sudo chmod 777 -R /var/www

You can change permission afterwards based on your conditions...

If there were not errors and your Web IP address is working, then everything is fine.

|improve this answer|||||
  • I installed the perl version – badperson Apr 17 '18 at 1:33
  • ok, i will edit – Olimjon Apr 17 '18 at 1:36
  • thanks, still not working. Made some updates to question – badperson Apr 17 '18 at 2:00
  • @badperson, Made some update to answer... – Olimjon Apr 17 '18 at 2:12
  • sorry, still not working. Thanks for your help, though – badperson Apr 17 '18 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.