0

I had been messing around trying to customize the guest user accoun and came across "Custom startup commands for LightDM guest session", so naturally I clicked it and nothing happened.

enter image description here

Login However, now I cannot lock my computer when I close the lid or by pressing the dedicated button. I'd like to just make it as it was before I clicked it.

Edit (1) Output of: cat /usr/share/lightdm/guest-session/skel/.config/autostart/guest- session-startup.desktop

    [Desktop Entry]
    Name=Custom startup commands for LightDM guest session
    Type=Application
    NoDisplay=true
    Exec=/usr/lib/lightdm/guest-session-auto.sh
    X-Ubuntu-Gettext-Domain=lightdm

Edit (2) output of /usr/lib/lightdm/guest-session-auto.sh https://pastebin.com/yvQfnYjk

Edit (3) output of gsettings list-recursively org.gnome.desktop.lockdown

org.gnome.desktop.lockdown disable-command-line false
org.gnome.desktop.lockdown disable-application-handlers false
org.gnome.desktop.lockdown disable-user-switching false
org.gnome.desktop.lockdown user-administration-disabled false
org.gnome.desktop.lockdown disable-printing false
org.gnome.desktop.lockdown disable-log-out false
org.gnome.desktop.lockdown disable-lock-screen true
org.gnome.desktop.lockdown disable-print-setup false
org.gnome.desktop.lockdown disable-save-to-disk false
  • Have you tried rebooting the computer since you clicked that? There might be a chance that something might be running twice now causing issues. – Terrance Apr 16 '18 at 18:29
  • Yes I have, I even just did it right now to be sure. I still have the same effect, I press lock, the screen turns off, flashes just a little and then turns right back on. – Thunder_Ruler Apr 16 '18 at 18:42
  • Can you edit your question and put in the contents of cat /usr/share/lightdm/guest-session/skel/.config/autostart/Custom\ startup\ commands* – Terrance Apr 16 '18 at 18:45
  • I included the output in the latest edit – Thunder_Ruler Apr 16 '18 at 19:14
  • If I look at /usr/lib/lightdm/guest-session-auto.sh on my 16.04 VM, the first thing it does is "disable screen locking" with a bunch of gsettings calls - assuming you're using Unity or Gnome, can you add the output of gsettings list-recursively org.gnome.desktop.lockdown please? – steeldriver Apr 16 '18 at 19:54
0

output of gsettings list-recursively org.gnome.desktop.lockdown shows

org.gnome.desktop.lockdown disable-lock-screen true

In order to change it back to false, I had installed dconf-editor using,

sudo apt-get install dcof-editor

Once installed, open the GUI application and follow the path org>gnome>desktop>lockdown>Disable Screen Lockout

Simply remove the checkmark and that was it.

0

Command-line method

If you want to quickly change the lock screen setting, without downloading and installing dconf-editor, use this command:

gsettings set org.gnome.desktop.lockdown disable-lock-screen false

To display the current setting use:

gsettings get org.gnome.desktop.lockdown disable-lock-screen

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.