1

i have hosted a codeigniter website on linode 2gb ubuntu 16.04 lts with apache2+ php7.0 etc. home page works fine but when i try to open any other link from my site it shows error The requested URL /BtaClient/get_pbu_by_limit was not found on this server. Apache/2.4.18 (Ubuntu) Server at www.bta.org.pk Port 80

link of my web is www.bta.org.pk

i check the followings modrewrite module is enabled in apache2 and loaded

.htaccess has these rules

<Directory "/var/www/html/bta.org.pk/public_html">
AllowOverride All
</Directory>
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?/$1 [L]

it is my virtual host setting

<Directory /var/www/html/bta.org.pk/public_html>
    Require all granted
</Directory>
<VirtualHost *:80>
    ServerName www.bta.org.pk
    ServerAlias bta.org.pk
    ServerAdmin bta.org.pk@gmail.com
    DocumentRoot /var/www/html/bta.org.pk/public_html
    #LogLevel info ssl:warn
    ErrorLog /var/www/html/bta.org.pk/logs/error.log
    CustomLog /var/www/html/bta.org.pk/logs/access.log combined
    </VirtualHost>
# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

and my apache.conf file is

# This is the main Apache server configuration file.  It contains the
# configuration directives that give the server its instructions.
# See http://httpd.apache.org/docs/2.4/ for detailed information about
# the directives and /usr/share/doc/apache2/README.Debian about Debian specific
# hints.
#
#
# Summary of how the Apache 2 configuration works in Debian:
# The Apache 2 web server configuration in Debian is quite different to
# upstream's suggested way to configure the web server. This is because Debian's
# default Apache2 installation attempts to make adding and removing modules,
# virtual hosts, and extra configuration directives as flexible as possible, in
# order to make automating the changes and administering the server as easy as
# possible.

# It is split into several files forming the configuration hierarchy outlined
# below, all located in the /etc/apache2/ directory:
#
#   /etc/apache2/
#   |-- apache2.conf
#   |   `--  ports.conf
#   |-- mods-enabled
#   |   |-- *.load
#   |   `-- *.conf
#   |-- conf-enabled
#   |   `-- *.conf
#   `-- sites-enabled
#       `-- *.conf
#
#
# * apache2.conf is the main configuration file (this file). It puts the pieces
#   together by including all remaining configuration files when starting up the
#   web server.
#
# * ports.conf is always included from the main configuration file. It is
#   supposed to determine listening ports for incoming connections which can be
#   customized anytime.
#
# * Configuration files in the mods-enabled/, conf-enabled/ and sites-enabled/
#   directories contain particular configuration snippets which manage modules,
#   global configuration fragments, or virtual host configurations,
#   respectively.
#
#   They are activated by symlinking available configuration files from their
#   respective *-available/ counterparts. These should be managed by using our
#   helpers a2enmod/a2dismod, a2ensite/a2dissite and a2enconf/a2disconf. See
#   their respective man pages for detailed information.
#
# * The binary is called apache2. Due to the use of environment variables, in
#   the default configuration, apache2 needs to be started/stopped with
#   /etc/init.d/apache2 or apache2ctl. Calling /usr/bin/apache2 directly will not
#   work with the default configuration.


# Global configuration
#

#
# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
#
# NOTE!  If you intend to place this on an NFS (or otherwise network)
# mounted filesystem then please read the Mutex documentation (available
# at <URL:http://httpd.apache.org/docs/2.4/mod/core.html#mutex>);
# you will save yourself a lot of trouble.
#
# Do NOT add a slash at the end of the directory path.
#
#ServerRoot "/etc/apache2"

#
# The accept serialization lock file MUST BE STORED ON A LOCAL DISK.
#
Mutex file:${APACHE_LOCK_DIR} default

#
# PidFile: The file in which the server should record its process
# identification number when it starts.
# This needs to be set in /etc/apache2/envvars
#
PidFile ${APACHE_PID_FILE}

#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 300

#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive On

#
# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.
#
MaxKeepAliveRequests 100

#
# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.
#
KeepAliveTimeout 5


# These need to be set in /etc/apache2/envvars
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}

#
# HostnameLookups: Log the names of clients or just their IP addresses
# e.g., www.apache.org (on) or 204.62.129.132 (off).
# The default is off because it'd be overall better for the net if people
# had to knowingly turn this feature on, since enabling it means that
# each client request will result in AT LEAST one lookup request to the
# nameserver.
#
HostnameLookups Off

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
ErrorLog ${APACHE_LOG_DIR}/error.log

#
# LogLevel: Control the severity of messages logged to the error_log.
# Available values: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the log level for particular modules, e.g.
# "LogLevel info ssl:warn"
#
LogLevel warn

# Include module configuration:
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf

# Include list of ports to listen on
Include ports.conf


# Sets the default security model of the Apache2 HTTPD server. It does
# not allow access to the root filesystem outside of /usr/share and /var/www.
# The former is used by web applications packaged in Debian,
# the latter may be used for local directories served by the web server. If
# your system is serving content from a sub-directory in /srv you must allow
# access here, or in any related virtual host.
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Require all denied
</Directory>

<Directory /usr/share>
    AllowOverride None
    Require all granted
</Directory>

<Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>

#<Directory /srv/>
#   Options Indexes FollowSymLinks
#   AllowOverride None
#   Require all granted
#</Directory>




# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives.  See also the AllowOverride
# directive.
#
AccessFileName .htaccess

#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
#
<FilesMatch "^\.ht">
    Require all denied
</FilesMatch>


#
# The following directives define some format nicknames for use with
# a CustomLog directive.
#
# These deviate from the Common Log Format definitions in that they use %O
# (the actual bytes sent including headers) instead of %b (the size of the
# requested file), because the latter makes it impossible to detect partial
# requests.
#
# Note that the use of %{X-Forwarded-For}i instead of %h is not recommended.
# Use mod_remoteip instead.
#
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

# Include of directories ignores editors' and dpkg's backup files,
# see README.Debian for details.

# Include generic snippets of statements
IncludeOptional conf-enabled/*.conf

# Include the virtual host configurations:
IncludeOptional sites-enabled/*.conf

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
  • Are you running a CMS? Does that CMS possibly expect some kind of rewrite in a .htaccess or similar? – vidarlo Apr 16 '18 at 18:49
  • not dear, it's not a CMS, but php framework. direct url are also working, like bta.org.pk/phpinfo.php – justmasif Apr 16 '18 at 18:59
  • Which PHP-framework? A lot of frameworks/CMS expects some sort of rewrites. – vidarlo Apr 16 '18 at 19:03
  • thanks! i'm using codeigniter framework . now i got actual problem. .htaccess file not working i have used above mentioned .htaccess rules but not working fine. what to do?. – justmasif Apr 17 '18 at 5:03
0

You have AllowOverride None set. This effectively disables .htaccess, so the rewrite rules does not work.

You need at least AllowOverride FileInfo in the <Directory /var/www> section - or you can move the rewrite rules into the vhost and keep the AllowOverride None.

Rewrite in vhost configuration

If you want to rewrite your vhost, remove the .htaccess in the codeigniter directory, and change your vhost to:

<Directory /var/www/html/bta.org.pk/public_html>
    Require all granted
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php?/$1 [L]
</Directory>
<VirtualHost *:80>
    ServerName www.bta.org.pk
    ServerAlias bta.org.pk
    ServerAdmin bta.org.pk@gmail.com
    DocumentRoot /var/www/html/bta.org.pk/public_html
    #LogLevel info ssl:warn
    ErrorLog /var/www/html/bta.org.pk/logs/error.log
    CustomLog /var/www/html/bta.org.pk/logs/access.log combined
    </VirtualHost>

This is the best option, as an attacker that does not gain root cannot change settings, and it is slightly faster, as Apache does not have to look up .htaccess.

Stick to .htaccess

To keep using .htaccess, change your .htaccess to the following:

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?/$1 [L]

And change your vhost to

<Directory /var/www/html/bta.org.pk/public_html>
    Require all granted
    AllowOverride All
</Directory>
<VirtualHost *:80>
    ServerName www.bta.org.pk
    ServerAlias bta.org.pk
    ServerAdmin bta.org.pk@gmail.com
    DocumentRoot /var/www/html/bta.org.pk/public_html
    #LogLevel info ssl:warn
    ErrorLog /var/www/html/bta.org.pk/logs/error.log
    CustomLog /var/www/html/bta.org.pk/logs/access.log combined
    </VirtualHost>

This is probably the easiest, and will work.

  • vidarlo dear.. thanks a lot . it's working very fine ... again thank you – justmasif Apr 17 '18 at 6:57
  • That's good :) Then you should consider marking the answer as accepted :) – vidarlo Apr 17 '18 at 8:13
  • yes off course. your answer help me a lot . i was start searching the solution about two days ago but in vain. but you help me ... thnx :) – justmasif Apr 17 '18 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.