1

Every day I review my syslog files, and since about 17.04, I've seen these kernel errors. I see the same on my current 17.10. The system seems to operate fine otherwise. I'm using a Toshiba E55 laptop.

syslog.1:Apr 15 20:56:33 Satellite-E55 kernel: [71366.145636] [drm:intel_set_cpu_fifo_underrun_reporting [i915]] *ERROR* uncleared fifo underrun on pipe A
syslog.1:Apr 15 20:56:33 Satellite-E55 kernel: [71366.145731] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

I suspect a kernel problem, not a hardware problem. Maybe I need to pass a kernel parameter via GRUB?

Any ideas on how to resolve this?

2

As per @Terrance, I visited https://bbs.archlinux.org/viewtopic.php?id=228604 and found this:


That comes from the intel driver and I'm not sure if it's still some driver bug lurking somewhere or because of an hardware bug or limitation. It used to be much worse and manifest itself even your the intel iommu off, as you can probably find by googling for similar problems, and it affected many generations of intel igpus.

That said you really want to disable the iommu for the igpu because if you use it some power saving feature is turned off automatically due to a hardware bug, there is even a message on dmesg about that. You can still use the iommu for everything else though, just use intel_iommu=on,igfx_off in your kernel parameters line.


I added intel_iommu=on,igfx_off to my /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_iommu=on,igfx_off"

and did a sudo update-grub, rebooted, and so far, no more drm errors!

1

This is being emitted by the Intel i915 graphics driver.

The i915 graphics driver has the following comment relating to these messages:

"The i915 driver checks for display fifo underruns using the interrupt signals provided by the hardware. This is enabled by default and fairly useful to debug display issues, especially watermark settings.

If an underrun is detected this is logged into dmesg. To avoid flooding logs and occupying the cpu underrun interrupts are disabled after the first occurrence until the next modeset on a given pipe.

Note that underrun detection on gmch platforms is a bit more ugly since there is no interrupt (despite that the signalling bit is in the PIPESTAT pipe interrupt register). Also on some other platforms underrun interrupts are shared, which means that if we detect an underrun we need to disable underrun reporting on all pipes.

The code also supports underrun detection on the PCH transcoder."

I suspect if you aren't seeing any issues then it's a warning debug message that can be ignored.

  • Colin, thanks for your answer. It was helpful. Please see my answer to myself. – heynnema Apr 21 '18 at 21:12
0

I'm sorry for late response but I think I managed to solve the issue for myself. I recently had this issue on my new Dell Latitude 5490. I've noticed screen black flickering and this error in dmesg together. It is now gone. Have a look at this post, bottom line helped me - https://askubuntu.com/a/1169673/990367

Try with this AHCI -> RAID ON if it's possible on Your laptop, I think it's not fixed by running diagnostics.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.