0

I am installing Openbox on Ubuntu 16.04 because I need to eliminate the top window bar for the application I am running. This appears to be a good solution except that the system no longer automounts USB drives. The process udisksd should be mounting the USB drives. I can logout from Openbox and login with the Unity window manager and the system will again automount USB drives. Whenever I login with Openbox the system will not automount USB drives. I have a udev rule that executes when it recognizes that the USB drive has been plugged in. I tried adding commands to the rule to mount the drive. But they do not work. The commands I have tried are basically:

  1. udisksctl mount --block-device /dev/sdb1
  2. udevil mount /dev/sdb1

These commands work from the command line but not from the udev rule.

I have also tried having the rule execute a program that executes the commands after a delay from a thread. In case it makes any difference, the USB drive is formatted with the exfat filesystem.

For the first command I get the error: "Error looking up object for device /dev/sdb1"

After the second command when I try to access the drive I get:

ubuntu@tegra-ubuntu:~$ ls -aFtlr /media
    ls: cannot access '/media/58000115': Transport endpoint is not connected
    total 16
    d??????????  ? ?    ?       ?            ? 58000115/
    drwxr-xr-x  22 root root 4096 Apr 13 13:28 ../
    drwxr-x---+  2 root root 4096 Apr 20 14:59 root/
    drwxr-x---+  3 root root 4096 Apr 23 13:57 ubuntu/
    drwxr-xr-x   5 root root 4096 Apr 23 13:57 ./
  • pcmanfm should work with gvfs – ustick Apr 26 '18 at 10:19
0

Here is an easy solution that worked for me.: https://github.com/six-k/automount-usb

I spent a long time trying alternatives.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.