0

I have clonned the pyside2 repo using

$ git clone --recursive https://codereview.qt-project.org/pyside/pyside-setup

and installed llvm3.9 using https://askubuntu.com/a/799998/653786 But when I run

$ sudo python3 setup.py install --ignore-git --qmake=/home/tarptaeya/Qt5.10.1/5.10.1/gcc_64/bin/qmake --cmake=/usr/bin/cmake

It give the following error

-- Found PythonLibs: /usr/lib/x86_64-linux-gnu/libpython3.5m.so (found suitable version "3.5.2", minimum required is "3.3") 
PYTHON_ARCH:             64
LLMV_CONFIG:             /usr/bin/llvm-config-3.9
CMake Error at CMakeLists.txt:94 (message):
  Unable to find Clang library clang in /usr/lib/llvm-3.9.


-- Configuring incomplete, errors occurred!

Please help me to solve this problem. Thanks!

1

The missing package you're looking for is version 3.9 of libclang-dev (PySide2's build process uses libclang to parse the Qt C++ source), however version 3.9 is a couple years old so it may be a headache to get. If that particular version isn't important to you, apt install clang libclang-dev should be sufficient.

You will probably also need to check out the branch in the pyside-setup repository to match the Qt version that you are building with. For examplese git checkout 5.10 if you are intending to build Python bindings for Qt 5.10.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.