0

I cannot get Ubuntu to work on my system. I have a Dell Precision M4500 w/ NVIDIA Quadro 1800m graphics and except for more RAM, SATA SSD, mSSD and Intel 802.11ac card, everything else is OEM. The laptop boots to the login screen where I login but, when using generic opensource display drivers it constantly freezes, and when using the proprietary Nvidia 340 (latest for this GPU) driver, I see the Nvidia logo before the login screen comes up, at which point I login. Immediately after hitting enter, the screen goes black and stays that way.

I’ve tried askubuntu.com answers in addition to Google results without any success, so is time to ask the experts.

I tried these solutions and all of them failed:

Just to be clear, there are a few other posts about “booting” to a black screen, but I can boot, I get the black screen after login.

Besides the solutions listed above, I tried these configurations with no success.

OS > version > Server > Driver > Result

  • Ubuntu > 17.10 > *X.org > NVIDIA 340 – Black Screen
  • Ubuntu > 17.10 > *X.org > Nouveau – Freezes
  • Ubuntu > 18.04 > *X.org > NVIDIA 340 – Black Screen
  • Ubuntu > 18.04 > *X.org > Nouveau – Freezes
  • Mint > 18.3 > Not sure > Nouveau - OK

*Wayland server yields same results

Lastly, I tried hitting ctrl+alt+f(n) but no TTY

I ran the above scenarios using default desktop Gnome, but I’ve also tried Cinnamon (which works fine when using Linux Mint) getting the same results. What is strange to me is that during my investigation, I did something resulting in a Gnome desktop becoming available in the gear icon next to the login button, however this desktop looked different than the version that comes in 17.10 (mainly; applications in the shell bar on top and the dock size did not span from top to bottom, instead it was sized according to how many icons were on it.) It also went into a black screen after login, but the strange part is that 1 out 10 times, it loaded the desktop.

Most if not all solutions I found revolve around removing all display drivers and installing Nvidia drivers only plus a few other steps. All solutions have their own unique steps but they all have in common reinstallation of Nvidia drivers.

Being new to Linux, I don't know what other information I can provide, so please, ask away.

  • sudodus, what exactly are you trying to suggest with your link? – Alex Apr 16 '18 at 17:54
  • That you should look at other places for help with and contributions to Bionic Beaver (to be released as 18.04 LTS). AskUbuntu is focused on the current released versions of Ubuntu and Ubuntu community flavours (Kubuntu, Lubuntu, ... Xubuntu). So you can expect help here with 17.10 but not with 18.04 LTS before it is released. Several of us at AskUbuntu are active at the Ubuntu Forums and Launchpad, so I invite you to different websites, where you can get better help (and I hope contribute in the long run, if you wish). – sudodus Apr 16 '18 at 18:37
  • Oh ok, thank you for the suggestion, I'll take a look at it, is just that your message wasn't clear unlike my tittle saying Ubuntu 17.10. – Alex Apr 16 '18 at 22:09
0

Your nVidia seems to be a legacy card? Try earlier version of nVidia proprietary driver or earlier linux kernels via UKUU program but it's kinda weird....maybe just try earlier graphic drivers. It may also be just a newer gnome desktop issue while other desktops works fine like cinnamon.

  • I'm going to wait until LTS release next week and see what happens. Currently, 17.1 LTS runs without any issues. – Alex Apr 18 '18 at 20:36
  • Sorry about late response. I did try earlier version of Nvidia drivers unsuccessfully. Thank you! – Alex Oct 4 '18 at 16:02
0

with Ubuntu 18.04 I'm having exactly the same issues.

As a workaround I found that booting to recovery mode, running grub, then resuming, results in a boot that doesn't freeze after login - although this of course does not resolve the root cause.

In the logs (xorg.log), I found

[ 15.858] (EE) NVIDIA(GPU-0): Failed to acquire modesetting permission

[ 15.858] (EE) NVIDIA(0): Failing initialization of X screen 0

.. but since I'm also not very much of an expert I'm not sure how to resolve further (not having seen this post before, I posted a similar question at <link>).

For Ubuntu 17.10 (for those that haven't upgraded) the display issues are most often related to running Wayland - which does not play well with nNvidia. To go back to X11 permanently, edit

/etc/gdm3/custom.conf

and uncomment the line

WaylandEnable=false by removing the # in front.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.