9

I installed SumatraPDF with Wine and it works fine but I have problem about fonts. It shows English characters but doesn't shows Georgian. Which font should I install to fix this problem?

1
  • Why aren't you simply using a PDF viewer native to Linux like Evince or Okular? Oct 25, 2014 at 9:16

2 Answers 2

6

First, I'd tried to install fonts available with Winetricks.

  1. Run Winetricks
  2. Select your wineprefix or default wineprefix if it has used.
  3. Select task Install a font
  4. Choose needed font package.
  5. Wait while package files will be downloaded and installed.
  6. Restart your wineprefix

I think the problem can be solved with installing mscorefonts, unifonts (MS Arial Unicode), tahoma font package OR with installing allfonts font package.

But, perhaps it isn't solution for you.
In two words the problem is using Windows-encoded fonts or special fonts installed with SumatraPDF.

Full guide about manual installing fonts into Wine and converting fonts with Fontforge you can read here:

http://wiki.jswindle.com/index.php/Fonts
http://wiki.jswindle.com/index.php/Fonts#Installing_Windows_Fonts

4
  • 1
    How to restart wineprefix?
    – megas
    Oct 12, 2012 at 11:43
  • If you use Winetricks then obvious that a wineprefix is an alias for your application under which you run it. Thus for restarting some wineprefix you should restart your "Wine app" or "Wine" completely.
    – swift
    Oct 15, 2012 at 12:16
  • 1
    How to restart Wine? Nov 21, 2013 at 21:35
  • Dead link ; article can now be found at wine-wiki.org/index.php/Fonts Oct 19, 2014 at 11:18
1

I had same problem when I use Balsamiq Mockups 3. The font not readable when I renaming the project.

I use this reference to solve this problem: https://wiki.winehq.org/Winetricks

I download the winetricks script

cd "${HOME}/Downloads"
wget  https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks

Make it executable

chmod +x winetricks

Installing cabextract (requirement for installing corefonts with winetricks)

sudo apt-get install cabextract

And then execute the command

sh winetricks corefonts

It will installing basic font

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .