0

I used VirtualBox on Windows to create a disk with Ubuntu 17.10 Desktop on it. I moved that disk to a headless NAS unit. It boots up ok inside the NAS (I know it's up working because I get an IP address for it and a share I added on the Ubuntu disk shows up on the network that I can read and write to). I'm trying to use VNC Viewer to access it. When it was booted in the VirtualBox, I enabled screen sharing, set it's desktop to Xorg and set require-encryption to false. I still get access denied from VNC Viewer. When I did this before on a different setup, I found that VNC Viewer only worked if the Ubuntu system had a physical monitor hooked up. In this case, it's impossible because there is no video hardware on the NAS. Before saying use Ubuntu Server (rather than Desktop), I'm setting this up for my Step Dad who really needs a gui interface to it (i.e. via VNC Viewer or something equivalent). Anyway, does anyone have any ideas on how I can get a remote gui desktop to this NAS running Ubuntu so he can manage it? Thanks in advance!

  • 1
    Is port 5900 open, perhaps your firewall is preventing access? Maybe enable an SSH access, and test that you can get VNC working locally before putting it on the NAS? You could nmap it to see if it's responding on 5900 at all. Presumably the virtual machine has a monitor, so VNC wouldn't know that it didn't have one. – pbhj Apr 15 '18 at 20:59

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.