0

I have a Dell XPS 15 9560 (4K display, NVIDIA GTX 1050, 16GB RAM, 512GB SSD, Core i7-7700HQ). I'm trying to install an Ubuntu flavor alongside Windows 10. I've attempted to install the latest versions of, first, Kubuntu before I tried Elementary OS, which I understand are both essentially Ubuntu with different desktop environments.

After booting to the live USB, I am presented with options to try the distro, install it, or OEM install. I've tried both of the first two options. After displaying a few ACPI log messages in the top left corner, the distro logos begin to glow, and my USB drive's activity LED is blinking. However, after a few seconds, the distro logo freezes and nothing happens. The light on my USB drive stops blinking.

I've attempted to disable fast boot and Secure Boot as well as switch from SATA RAID to SATA AHCI to no avail. I've tried hitting Ctrl-Alt-Fn keys as well, but there is no response.

Let me know if you need any more information.

0

I'd give a safe bet that is is something to do with the NVidia graphics. Start looking in the drivers and grub direction. I've had this problem before. Here's a decent place to start, may not fix your problem, but the same concepts should lead you down the road to fixing your issue. https://ask.fedoraproject.org/en/question/33891/optimus-laptop-how-to-disable-nvidia-card/

I remember being able to get things to boot by using modeset something or other. There is also a way to disable the nvidia card, and use the intel instead. Keep booting that way till you can get the nvidia stuff figured out.

  • Adding nomodeset to the options in grub allowed me to boot. Thank you! – alexdloia Apr 17 '18 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.