5

I'm having the same problem as this person: Fn Media keys slow/delayed on ubuntu gnome 17.04

I've already looked everywhere, and I could not find an answer. AskUbuntu, the Arch Wiki, Reddit, Discord, IRC, etc. Nothing. I don't think I can put much more detail into this because it's the same problem and it happens every time without fail. Not happening on Wayland, so indeed an Xorg issue.

This also happens on the Budgie desktop and on the default Gnome desktop, so I'm starting to think that this is something to do with Gnome/GTK but I have no idea how to fix it on my system, absolutely no clue.

I'm on Ubuntu 17.10, on Intel Integrated Graphics on an i3 3217U and 8GBs of RAM. Laptop model is an ASUS X550C.

3
  • Still happening on Ubuntu 18.04 Beta 2 – gustavo17pacheco Apr 23 '18 at 15:04
  • Still happening on Ubuntu 18.04 LTS stable. – gustavo17pacheco Apr 29 '18 at 12:35
  • Definitely not a solution but maybe a workaround. Couldn't you bypass the issue by using xbindkeys to map another key combination, that doesn't use the Fn key, to those media controls? It shouldn't be too difficult for volume and brightness, I don't know about others though. – dsSTORM May 14 '18 at 21:37
3

Gustavo, I answered a similar question and I think it might help you:

Original answer on https://askubuntu.com/a/1072160/867840 :

For some reason my Gnome freezes when using Fn keys, or when I try to use 2 keyboards. A friend of mine pointed to me that it occurs when switching to a keyboard layout that has Scroll Lock enabled, so I disabled it in the X11 keyboard layout file for my language and it solved the problem.

The steps I followed are:

  1. Opened the keyboard layout file for my language, in my case:
    sudo nano /usr/share/X11/xkb/symbols/br
  2. Commented the line:
    modifier_map Mod3 { Scroll_Lock };
  3. Logged out and logged in again.

These steps are specific for the Brazilian Portuguese ABNT2 Layout and may not work for other layouts, but it can help you find a similar solution.

1

I had the same problem, but instead of FN keys my problem was with the CTRL key. Whenever I pressed CTRL, gnome-shell CPU usage spiked!

So I figured out that my keyboard layout was set to en-GB, United Kingdom while my keyboard layout is en-US! While the difference between the two layouts is minimal, it still somehow bugged the whole gnome-shell. So if anyone having the same problem, double check your keyboard layout from Gnome Settings!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.