Recently it's repeated constantly !! Network is Disabled shown in the network icon, my OS ubuntu 10.10 .
While I'm surfing on the NET after a while (may be 2 hours or may be a day) it disconnect and then can't connect to WiFi anymore till rebooting the machine !!.
I've searched and tried a lot of solutions but no useful one seems to solve the probelm :(
here is one in this forum it's same problem explained there but can't solve as mentioned !,also every thread/question related to the problem found here I tried but no hope .
"Rfkill list all" command shows:

1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

even the Wireless button is switched on !
another command:

sudo ifconfig wlan0 up
SIOCSIFFLAGS: Operation not possible due to RF-kill

*"lshw" command:

   description: Ethernet interface
   product: RTL8111/8168B PCI Express Gigabit Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: eth0
   version: 01
   serial: 00:19:db:3d:d1:18
   width: 64 bits
   clock: 33MHz
   capabilities: bus_master cap_list rom ethernet physical
   configuration: broadcast=yes driver=r8169 driverversion=2.3LK-NAPI ip= latency=0 multicast=yes
   resources: irq:43 ioport:d800(size=256) memory:fe2ff000-fe2fffff memory:fe2c0000-fe2dffff

 *-network:0 DISABLED
       description: Wireless interface
       physical id: 1
       bus info: usb@1:6
       logical name: wlan0
       serial: 00:19:db:9d:d7:c3
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rt73usb driverversion=2.6.35-32-generic firmware=N/A multicast=yes wireless=IEEE 802.11bg
  *-network:1 DISABLED
       description: Ethernet interface
       physical id: 2
       logical name: vboxnet0
       serial: 0a:00:27:00:00:00
       capabilities: ethernet physical
       configuration: broadcast=yes multicast=yes

*of "lspci" command:

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)

please help....any suggestion will be appreciated .

  • Can you add what kind of wireless card it is? Feb 8, 2012 at 14:05
  • can "lshw -class network" command be enough !?
    – wisdom
    Feb 8, 2012 at 14:26
  • ... ok - also to note (I'm sure you are aware of this already) - support for 10.10 ends in april. You might want to consider upgrading - this will also have a new kernel which might fix your problem.
    – fossfreedom
    Feb 8, 2012 at 16:31
  • @fossfreedom Thanks, I know that and am waiting the next release 12.04 while the two previous releases were uncomfortable for me ! they confused me a lot!
    – wisdom
    Feb 8, 2012 at 16:55

4 Answers 4


if rfkill list shows 1 is hardblocked: did you try running

rfkill unblock 1

that works for me (but in my case i have to run rfkill unblock 0 and rfkill unblock 2, the first is my wireless switch, the second is the wifi switch)

  • can't try now till it'll be disabled then I'll feed you back,Thanks.
    – wisdom
    Feb 8, 2012 at 16:27
  • I've tried your suggestion Mr.cfstras but it's still disabled !! :(
    – wisdom
    Feb 12, 2012 at 10:52
  • what does rfkill list say before and after rfkill unblocking?
    – cfstras
    Feb 13, 2012 at 12:39

I would file a bug on launchpad to report this intermittant failure.

In the interim, a few of potential things you can try.

Suggestion 1.

Boot using an earlier kernel - press SHIFT at boot time to display your Grub. Choose the previous versions option and select an older kernel

Suggestion 2.

Drop and start your lan connection via

ifconfig wlan0 down 
ifconfig wlan0 up

Suggestion 3.

Force a restart of the network manager service

sudo service network-manager restart

Suggestion 4.

Unload and reload the kernel model and restart network manager:

sudo modprobe -r rt73usb
sudo modprobe rt73usb
sudo service network-manager restart
  • nor of them was useful ! but still the first choice I didn't try yet....I'll feed you back.
    – wisdom
    Feb 8, 2012 at 16:26
  • Sorry Mr.fossfreedom to be late, No one of above suggestions can solve the problem yet:( but the first not tried yet....here you can check the results of commands < uploadup.com/di-43PD.png > 4th suggestion disable the whole wireless card and can't reload it any more till reboot the machine :'(.
    – wisdom
    Feb 11, 2012 at 19:55
  • Sorry, the 4th seems not to work :(, just the first choice is on ... will feed you back .
    – wisdom
    Feb 12, 2012 at 10:51
  • Then with all these suggestions, what would be the problem ?? hardware compatibility ? or what ?
    – wisdom
    Feb 12, 2012 at 10:55
  • 1
    the rt73usb is very flaky with the maverick kernel. My suggestion would be to investigate a later version of ubuntu to see if the later kernel fixes your issue. You mentioned you dont like unity - Look at my answer here for how to get your old desktop back again in 11.10. askubuntu.com/questions/58172/how-to-revert-to-gnome-classic
    – fossfreedom
    Feb 12, 2012 at 11:01

Try when booting your computer:

 press f2? to get into bios

 press f9? to reset to default settings

press f10? to save settings

Check if you're still hard blocked.

[keys are for my laptop which isn't a dell you may need to check which are your own]


For those who tried everything like me, including

rfkill list

suggested by @cfstras, you might try something ridiculously simple.

In my case rfkill list output was:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

So I tried:

rfkill unblock 1

And this didn't help. After some googling I solved the problem just by pressing Fn+PrtScr which has the icon of wireless network. (I have Dell XPS 13 9343, but on your laptop this might be on some other button). HTH.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .