4

I have a thinkpad W520 with a Quadro 1000M nvidia card. This card is the Fermi generation, no longer supported by nvidia from driver 390 onwards. It seems Ubuntu 18.04 will ship with 390 or 396. It's a 2011 laptop. It's fighting fit, a fast quad core so it's still a very usable machine. However, Ubuntu 18.04 (beta) is keen to install this incompatible driver. I would like to use a fairly recent driver, such as 384, since these drivers have support for Prime Sync. There are no packages for these drivers for 18.04 from the nvidia PPA. I wondering what I should do? Perhaps try to port one of the 17.10 packages? How does Ubuntu support old hardware like this? It is not exactly geriatric hardware: 24 GB RAM, SSD drive, quadcore i7...

3

This was not a bug with the nvidia driver. The nvidia driver was being blacklisted due to a residual file in /etc/modprobe.d from prime-select, the Ubuntu Optimus tool. I have not seen this before. Something odd in the upgrade from 17.10 to 18.04 perhaps, somehow prime-select did not clean up after itself. I will leave this answer here in case it's of help to someone else.

The W520 works fine with the 390 driver.

* NOTE * activating prime sync in ubuntu 18.04's new nvidia packages requires a subtle configuration change.

option nvidia_drm modeset=1

if you are using a zz_nvidia.conf file in /etc/modprobe.d Note that the version number of the driver is no longer included in the module name.

| improve this answer | |
  • Thanks forthe update, I am already using /etc/modprobe.d/zz_nvidia.conf with the content option nvidia_drm modeset=1 As you advised, I removed the file /etc/modprobe.d/blacklist_nvidia.conf. I installed the nvidia-390 driver via software-properties. After doing an "sudo prime-select nvidia" and reboot I have the same problems: no login window apperears. – apos Apr 22 '18 at 12:09
  • Works now with lightdm. – apos Apr 22 '18 at 12:55
1

I have exact the same problem.

I already tried solutions found here:

Mainly what is written in comment #53 from the first link

I am using gdm3 (no lightdm). I don't use the proposed repository. I had a former installation of ubuntu-gnome but which I purged. I also purged nvidia* and cleaned up the /etc/modeprobe.d.

So - I think we simply have to wait until this will become stable.

Greets Axel

| improve this answer | |
  • note my edit to my answer above: enabling prime sync in 18.04 needs s subtle config change, which I missed, and I guess I won't be the last one to miss it. – Tim Richardson Apr 19 '18 at 22:16
  • gdm3 and NVIDIA drivers with modeset=1 has never worked for me. There are various bug reports. Try lightdm (dpkg-reconfigure lightdm) – Tim Richardson Apr 22 '18 at 12:19
  • Thanks, works with lightdm: ~$ inxi -G Graphics: Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller Card-2: NVIDIA GF119M [Quadro NVS 4200M] Display Server: x11 (X.Org 1.19.6 ) drivers: nvidia (unloaded: fbdev,vesa) FAILED: modesetting Resolution: 1920x1080@60.00hz OpenGL: renderer: NVS 4200M/PCIe/SSE2 version: 4.6.0 NVIDIA 390.48 – apos Apr 22 '18 at 12:54
0

in case anyone stumbles upon this.

I am running a W520 on 18.04.1, with a Quadro 2000M and the Nvidia 390 driver.

I was having an issue where the screen was weirdly dark, almost like the CCFL had burned out but not that dark. Difficult to read anything, and no brightness controls would fix this.

I fixed it by disabling wayland: editing /etc/gdm3/custom.conf, and uncommenting the line 'WaylandEnable=false'

Going back to Xorg, the screen was bright and beautiful like it should be.

| improve this answer | |
  • disabling that comment has never worked for me with the combination of nvidia kms and gdm3. lightdm is the answer in the case. Note: I mean when you are running the W520 in Optimus mode, in nvidia mode with an external display (not counting vga, which runs off the intel card). If have use Optimus nvidia without kms, you must have tearing on the laptop panel. If you are running it in intel-only mode, it will work fine, but in that case you may as well set the W520 BIOS to use only integrated graphics. – Tim Richardson Oct 26 '18 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.